summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-08 04:53:15 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-08 05:07:55 +0200
commitada30dd6abc24586dca2ca7530b3863ecf459e57 (patch)
treeac5c9d8efa5885a17ce223c812e91219a993f99b /dev-python/crc32c
parentdev-python/sphinx-prompt: Bump to 1.9.0 (diff)
downloadgentoo-ada30dd6abc24586dca2ca7530b3863ecf459e57.tar.gz
gentoo-ada30dd6abc24586dca2ca7530b3863ecf459e57.tar.bz2
gentoo-ada30dd6abc24586dca2ca7530b3863ecf459e57.zip
dev-python/crc32c: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/crc32c')
-rw-r--r--dev-python/crc32c/Manifest1
-rw-r--r--dev-python/crc32c/crc32c-2.4.ebuild51
-rw-r--r--dev-python/crc32c/files/crc32c-2.4-sparc.patch34
3 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/crc32c/Manifest b/dev-python/crc32c/Manifest
index 760df9c9fcc6..3b3b98df1856 100644
--- a/dev-python/crc32c/Manifest
+++ b/dev-python/crc32c/Manifest
@@ -1,2 +1 @@
DIST crc32c-2.4.1.tar.gz 38277 BLAKE2B 3d4a0eeb5811e8bc46df30b8890ab409de92dc3cfe2c5c3ab355df3394e56812c19ac26523be2cf9c33bb5825fb6e080b6f27ea77bed5c38d98fbe6c247653fb SHA512 005f95f66e97f552a83b5c94b706224f44280895d70c348fee86943bf1589a94b57eeddde5e18499fea9c77cbcbcfd5691d9d4b33ed788dc885a1333b6db476b
-DIST crc32c-2.4.tar.gz 38272 BLAKE2B 1273f62794bd646e983737d922c4e1320a4519856b1cedf2d1d1f9b1e47fc767e248b6e00ada48e8f245e47fc18619327e9a8cfa5d88a0569c467ca6147a1974 SHA512 d747dee42184ff025dd6fd7334b65e5caba4066a055943a783b951d09e09339694072ea552aa95579f03a85a7bdb2eb4a8d12dc9a17f0f83d84c0fde534b36cb
diff --git a/dev-python/crc32c/crc32c-2.4.ebuild b/dev-python/crc32c/crc32c-2.4.ebuild
deleted file mode 100644
index 2444827a45f7..000000000000
--- a/dev-python/crc32c/crc32c-2.4.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="CRC32c algorithm in hardware and software"
-HOMEPAGE="
- https://github.com/ICRAR/crc32c/
- https://pypi.org/project/crc32c/
-"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~sparc ~x86"
-# NB: these don't affect the build, they are only used for tests
-IUSE="cpu_flags_arm_crc32 cpu_flags_x86_sse4_2"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/ICRAR/crc32c/pull/44
- "${FILESDIR}/${P}-sparc.patch"
-)
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x CRC32C_SW_MODE
-
- # force = run "software" code (i.e. unoptimized)
- # none = run "hardware" code (i.e. SSE4.2 / ARMv8 CRC32)
- for CRC32C_SW_MODE in none force; do
- if [[ ${CRC32C_SW_MODE} == none ]]; then
- if ! use cpu_flags_arm_crc32 && ! use cpu_flags_x86_sse4_2; then
- continue
- fi
-
- # the test suite just skips all tests, so double-check
- "${EPYTHON}" -c "import crc32c" ||
- die "Importing crc32c failed (accelerated code path broken?)"
- fi
-
- einfo "Testing with CRC32C_SW_MODE=${CRC32C_SW_MODE}"
- epytest
- done
-}
diff --git a/dev-python/crc32c/files/crc32c-2.4-sparc.patch b/dev-python/crc32c/files/crc32c-2.4-sparc.patch
deleted file mode 100644
index f2e96638d51b..000000000000
--- a/dev-python/crc32c/files/crc32c-2.4-sparc.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 9d94ecbfe2363c7adf49bddbf31871764faf4f41 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sun, 30 Jun 2024 16:00:34 +0200
-Subject: [PATCH] Fix char signedness issue in _crc32c_sw_slicing_by_8()
-
-Fix `_crc32c_sw_slicing_by_8()` to use `unsigned char` for `p_buf`,
-to fix incorrect results on platforms with signed `char` such as SPARC.
-The code has been casting `unsigned char *` to `char *` for no apparent
-reason, and this broke the bitshifts in the big endian blocks.
-
-Particularly,
-
- crc ^= *(p_buf++) << 16
-
-would be XOR-ed against `0xffee0000` rather than `0x00ee0000`.
-
-Fixes #43
----
- crc32c_sw.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/crc32c_sw.c b/crc32c_sw.c
-index 8382749..67409c9 100644
---- a/crc32c_sw.c
-+++ b/crc32c_sw.c
-@@ -490,7 +490,7 @@ const uint32_t crc_tableil8_o88[256] =
-
- uint32_t _crc32c_sw_slicing_by_8(uint32_t crc, unsigned const char* data, unsigned long length)
- {
-- const char* p_buf = (const char*) data;
-+ unsigned const char* p_buf = data;
- size_t initial_bytes = (sizeof(uint32_t) - (intptr_t)p_buf) & (sizeof(uint32_t) - 1);
- size_t li;
- size_t running_length;