summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-17 15:22:14 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-17 15:23:52 +0100
commitb723f4331e032ac59ca2502b738838d35f01c394 (patch)
tree64f8156e3246b802db6d998edd5bb2e9eaf173ea /dev-python/cryptography
parentmedia-radio/tlf: Fix missing RESTRICT="!test ( test )" (diff)
downloadgentoo-b723f4331e032ac59ca2502b738838d35f01c394.tar.gz
gentoo-b723f4331e032ac59ca2502b738838d35f01c394.tar.bz2
gentoo-b723f4331e032ac59ca2502b738838d35f01c394.zip
dev-python/cryptography: Inline cryptography_vectors
Closes: https://bugs.gentoo.org/700342 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cryptography')
-rw-r--r--dev-python/cryptography/Manifest1
-rw-r--r--dev-python/cryptography/cryptography-2.8.ebuild16
2 files changed, 12 insertions, 5 deletions
diff --git a/dev-python/cryptography/Manifest b/dev-python/cryptography/Manifest
index ee134edad07e..e95ee2ffaf8c 100644
--- a/dev-python/cryptography/Manifest
+++ b/dev-python/cryptography/Manifest
@@ -1,2 +1,3 @@
DIST cryptography-2.6.1.tar.gz 491580 BLAKE2B b81114b57e9973c80fe999a63a3b1269d6289ac67851fedc263927b74e9e5ec4f35356cf5d46e4a27a994d5a3b2b3b599fea264b3ebce3a0cac27abfde3ef046 SHA512 f14319e24d9dca52e74548cada5b78a6235f089ef875dbff4799e862f94da8b087f1b6e03e84dcef9fc7d7693c4a349c5f0cd54b8535806da777420ce8757d39
DIST cryptography-2.8.tar.gz 504516 BLAKE2B 3a853bf59a752acee9e9607f3f35f3815701c6068a1ffa5b6604ec648a31a5d4e31f13a1b19f3156c703313800242d8b06dd71a54a4eb0cc68481dea894002f3 SHA512 bf3ca44123c693b0602be19445925f9efebd46c469909e47b7907d57141fb6bd99268c33e1fe3f42a08ab8b4edd4f98f21b6a682f530352313334dfd31ba91e7
+DIST cryptography_vectors-2.8.tar.gz 35102030 BLAKE2B 8e98e12bab31a2097a72c849f52ee93b9b684a8923c140722419154471bd695c6287ff4498c9fe326662c7d9a9f5d9ebaa55dc4d5a0d8180a6827ae244464006 SHA512 d328082d3a65b8036d396172d7e42c753c842e9310850a77c6ccd99c9905d48bbc3e3319d216013c1370b8439f0f8056749ae94b1abf9a5b7088435acdeed7fb
diff --git a/dev-python/cryptography/cryptography-2.8.ebuild b/dev-python/cryptography/cryptography-2.8.ebuild
index 0a68d221c48b..777545258fb7 100644
--- a/dev-python/cryptography/cryptography-2.8.ebuild
+++ b/dev-python/cryptography/cryptography-2.8.ebuild
@@ -8,14 +8,17 @@ PYTHON_REQ_USE="threads(+)"
inherit distutils-r1 flag-o-matic
+VEC_P=cryptography_vectors-${PV}
DESCRIPTION="Library providing cryptographic recipes and primitives"
HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.org/project/cryptography/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ test? ( mirror://pypi/c/cryptography_vectors/${VEC_P}.tar.gz )"
LICENSE="|| ( Apache-2.0 BSD )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="libressl idna"
+IUSE="libressl idna test"
+RESTRICT="!test? ( test )"
# the openssl 1.0.2l-r1 needs to be updated again :(
# It'd theb be able to go into the || section again
@@ -43,19 +46,22 @@ DEPEND="${RDEPEND}
$(python_gen_cond_dep '>=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]' 'python*')
$(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
test? (
- ~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
dev-python/pretend[${PYTHON_USEDEP}]
dev-python/iso8601[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
>=dev-python/hypothesis-1.11.4[${PYTHON_USEDEP}]
!~dev-python/hypothesis-3.79.2[${PYTHON_USEDEP}]
dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
)"
DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
-distutils_enable_tests pytest
-
python_configure_all() {
append-cflags $(test-flags-CC -pthread)
}
+
+python_test() {
+ local -x PYTHONPATH=${PYTHONPATH}:${WORKDIR}/${VEC_P}
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}