summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-11 13:27:24 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-11 14:24:05 +0200
commit5c812f9d338aeef6c7bedc6ad856cd849ef5edb7 (patch)
tree1e277098ad80ae5427822595131f24a39d4d98b1 /dev-python/distro
parentdev-vcs/git-filter-repo: Bump to 2.38.0 (diff)
downloadgentoo-5c812f9d338aeef6c7bedc6ad856cd849ef5edb7.tar.gz
gentoo-5c812f9d338aeef6c7bedc6ad856cd849ef5edb7.tar.bz2
gentoo-5c812f9d338aeef6c7bedc6ad856cd849ef5edb7.zip
dev-python/distro: Bump to 1.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/distro')
-rw-r--r--dev-python/distro/Manifest1
-rw-r--r--dev-python/distro/distro-1.8.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/distro/Manifest b/dev-python/distro/Manifest
index fbb1ae14b67a..08c6d87dddf6 100644
--- a/dev-python/distro/Manifest
+++ b/dev-python/distro/Manifest
@@ -1 +1,2 @@
DIST distro-1.7.0.tar.gz 58164 BLAKE2B 22bbd2daf9cac589530eac9a58767db6b9e389b77719516f7386a9377b49ba4c9b696165701acc42366b760b9a632c70a2243a58c12a367fef2a0a770a4aea44 SHA512 14516ecab33ee8c57c35a8279eb515fd699031fabac7d8886092ea98696797d55503179870aeb513a85e1a66c7e69f2f60bb6ea9fc935be975cb5135e1917ecc
+DIST distro-1.8.0.tar.gz 59428 BLAKE2B d1b47dd801c4414a6bb21c544c62c306a1cf49b43f70974f7a0b4bcba64620047c7d06b6507ba262eba44d2f192f654646bb69241ed5bf6b761dc9d42e049e18 SHA512 027fe8bc50e263dc49451932774f32cea7900820b6e30cc80afcdc84374777ba733137fdd8d27fec76f66ce9c579bc172721e7ae0f43e72dffbc092126b26af2
diff --git a/dev-python/distro/distro-1.8.0.ebuild b/dev-python/distro/distro-1.8.0.ebuild
new file mode 100644
index 000000000000..450a7bea04af
--- /dev/null
+++ b/dev-python/distro/distro-1.8.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Reliable machine-readable Linux distribution information for Python"
+HOMEPAGE="
+ https://distro.readthedocs.io/en/latest/
+ https://github.com/python-distro/distro/
+ https://pypi.org/project/distro/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest