summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-10 23:59:33 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-11 00:56:08 +0100
commit4dc9e0d4e4e87edc8ceaf9186f1e7bde88fb044c (patch)
tree67c97648a6f0d8d284f9abe66be4fac8123e6697 /dev-python/django-js-asset
parentdev-python/Faker: Remove old (diff)
downloadgentoo-4dc9e0d4e4e87edc8ceaf9186f1e7bde88fb044c.tar.gz
gentoo-4dc9e0d4e4e87edc8ceaf9186f1e7bde88fb044c.tar.bz2
gentoo-4dc9e0d4e4e87edc8ceaf9186f1e7bde88fb044c.zip
dev-python/django-js-asset: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-js-asset')
-rw-r--r--dev-python/django-js-asset/Manifest1
-rw-r--r--dev-python/django-js-asset/django-js-asset-1.2.2.ebuild33
-rw-r--r--dev-python/django-js-asset/files/django-js-asset-1.2.2-fix-django3.patch55
3 files changed, 0 insertions, 89 deletions
diff --git a/dev-python/django-js-asset/Manifest b/dev-python/django-js-asset/Manifest
index f87a34185d01..62e9dc794edf 100644
--- a/dev-python/django-js-asset/Manifest
+++ b/dev-python/django-js-asset/Manifest
@@ -1,2 +1 @@
-DIST django-js-asset-1.2.2.gh.tar.gz 6367 BLAKE2B 5b24d3a2cf1ca2b28b82e581541dcb58aa2bf25d99f865007730c00211452dc5a062dc014b47fd1d10020d2a0b8f74060910460dec4f95be2b83c5c6d7bfb4d2 SHA512 ad2c51399da9b5d75305c0fa257cc75496df3f6704a827a0d297a4d762712039c3ebd921afbe6e10672626f1badd8637728292dd700ba41c4192c95ec73095a9
DIST django-js-asset-2.0.gh.tar.gz 7386 BLAKE2B 5bebddc68a6d77b9ffc4c685cfcf0c34d03a82d1f24ea0bc64f35e70bf3a736fc8be612fba1e21bfbe1cb646363f06d0d001822209e15034cb03c337c80d24fd SHA512 0ec4954952394d90946d0653e86ecf45eb83ceaeb99bfde1eeed68f471110b85260abd7ae69f5b2c318e4341c09fd31efb781825d74164dc8ac6bd94bcb6f8e7
diff --git a/dev-python/django-js-asset/django-js-asset-1.2.2.ebuild b/dev-python/django-js-asset/django-js-asset-1.2.2.ebuild
deleted file mode 100644
index 5704b6a31f05..000000000000
--- a/dev-python/django-js-asset/django-js-asset-1.2.2.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="script tag with additional attributes for django.forms.Media"
-HOMEPAGE="https://github.com/matthiask/django-js-asset"
-SRC_URI="
- https://github.com/matthiask/django-js-asset/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/django-1.17[${PYTHON_USEDEP}]"
-BDEPEND="test? ( ${RDEPEND} )"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-django3.patch"
-)
-
-python_test() {
- cd tests || die
- local -x DJANGO_SETTINGS_MODULE=testapp.settings
- django-admin test -v 2 || die
-}
diff --git a/dev-python/django-js-asset/files/django-js-asset-1.2.2-fix-django3.patch b/dev-python/django-js-asset/files/django-js-asset-1.2.2-fix-django3.patch
deleted file mode 100644
index 4ab0484b17e0..000000000000
--- a/dev-python/django-js-asset/files/django-js-asset-1.2.2-fix-django3.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 232536ba50a2e1a0cffc6046dbcdfdec22cb0d9e Mon Sep 17 00:00:00 2001
-From: Matthias Kestenholz <mk@feinheit.ch>
-Date: Fri, 15 May 2020 08:51:33 +0200
-Subject: [PATCH] Adapt the test suite to changes in Django
-
---- a/tests/testapp/test_js_asset.py
-+++ b/tests/testapp/test_js_asset.py
-@@ -1,11 +1,15 @@
- from __future__ import unicode_literals
-
-+import django
- from django.forms import Media
- from django.test import TestCase
-
- from js_asset.js import JS
-
-
-+JS_TYPE = ' type="text/javascript"' if django.VERSION < (3, 1) else ""
-+
-+
- class AssetTest(TestCase):
- def test_asset(self):
- media = Media(
-@@ -25,15 +29,17 @@ def test_asset(self):
- html,
- )
- self.assertInHTML(
-- '<script type="text/javascript" src="/static/app/test.js"></script>', # noqa
-+ '<script{} src="/static/app/test.js"></script>'.format(JS_TYPE), # noqa
- html,
- )
- self.assertInHTML(
-- '<script type="text/javascript" src="/static/app/asset.js" data-the-answer="42" id="asset-script"></script>', # noqa
-+ '<script{} src="/static/app/asset.js" data-the-answer="42" id="asset-script"></script>'.format( # noqa
-+ JS_TYPE
-+ ),
- html,
- )
- self.assertInHTML(
-- '<script type="text/javascript" src="/static/app/asset-without.js"></script>', # noqa
-+ '<script{} src="/static/app/asset-without.js"></script>'.format(JS_TYPE),
- html,
- )
-
-@@ -42,7 +48,9 @@ def test_absolute(self):
- html = "%s" % media
-
- self.assertInHTML(
-- '<script type="text/javascript" src="https://cdn.example.org/script.js"></script>', # noqa
-+ '<script{} src="https://cdn.example.org/script.js"></script>'.format(
-+ JS_TYPE
-+ ),
- html,
- )
-