summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/django-oauth-plus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/django-oauth-plus')
-rw-r--r--dev-python/django-oauth-plus/Manifest1
-rw-r--r--dev-python/django-oauth-plus/django-oauth-plus-2.2.8.ebuild35
-rw-r--r--dev-python/django-oauth-plus/metadata.xml8
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/django-oauth-plus/Manifest b/dev-python/django-oauth-plus/Manifest
new file mode 100644
index 000000000000..75203ab53072
--- /dev/null
+++ b/dev-python/django-oauth-plus/Manifest
@@ -0,0 +1 @@
+DIST django-oauth-plus-2.2.8.tar.gz 25911 SHA256 a9b08d846e23ce0227de8ccce72d453d3618a3de4f83959da2ae75f76b627867 SHA512 9237a2e2e52923b2fdfd3b7feff63e11f2c06c871faca3455189edba233e2a6513169481092f413c3ddea1c919f4b995fb465a505935388f1d803d094942ee07 WHIRLPOOL 9bf83c5052314cc1174ba4080653992569672a7c47a5b78896d7220b099346ac40e1a0f4c81738ec2638b76e942083953eb11e37925c2582cae5a5d098d49132
diff --git a/dev-python/django-oauth-plus/django-oauth-plus-2.2.8.ebuild b/dev-python/django-oauth-plus/django-oauth-plus-2.2.8.ebuild
new file mode 100644
index 000000000000..ede060f4f279
--- /dev/null
+++ b/dev-python/django-oauth-plus/django-oauth-plus-2.2.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+# Testsuite written for py2 only, no indication given in source
+
+inherit distutils-r1
+
+DESCRIPTION="Support of OAuth 1.0a in Django using python-oauth2"
+HOMEPAGE="http://pypi.python.org/pypi/django-oauth-plus http://code.welldev.org/django-oauth-plus/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/django-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oauth2-1.5.170[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_test() {
+ PYTHONPATH=.:oauth_provider
+ if "${PYTHON}" oauth_provider/runtests/runtests.py; then
+ einfo "Testsuite passed under ${EPYTHON}"
+ else
+ die "Testsuite failed under ${EPYTHON}"
+ fi
+}
diff --git a/dev-python/django-oauth-plus/metadata.xml b/dev-python/django-oauth-plus/metadata.xml
new file mode 100644
index 000000000000..81c84aa20e28
--- /dev/null
+++ b/dev-python/django-oauth-plus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">django-oauth-plus</remote-id>
+ </upstream>
+</pkgmetadata>