summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-17 10:18:43 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-17 10:55:39 +0100
commit19d9418855cb4fe39d5fc302c0b62e73864ccbd1 (patch)
tree3f645fcda13191cee33593313393d97a95ade8ec /dev-python/django-taggit
parentdev-python/rich: Bump to 10.14.0 (diff)
downloadgentoo-19d9418855cb4fe39d5fc302c0b62e73864ccbd1.tar.gz
gentoo-19d9418855cb4fe39d5fc302c0b62e73864ccbd1.tar.bz2
gentoo-19d9418855cb4fe39d5fc302c0b62e73864ccbd1.zip
dev-python/django-taggit: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-taggit')
-rw-r--r--dev-python/django-taggit/Manifest1
-rw-r--r--dev-python/django-taggit/django-taggit-2.0.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/django-taggit/Manifest b/dev-python/django-taggit/Manifest
index 8a817f56af87..351560cf2e8d 100644
--- a/dev-python/django-taggit/Manifest
+++ b/dev-python/django-taggit/Manifest
@@ -1 +1,2 @@
DIST django-taggit-1.5.1.tar.gz 52766 BLAKE2B 59892ba591ad5cbc40a7515a6427722d7cb58e2daadec579b1c08dcc3522e24e041cbe06c953c3717cdf3db50aef7ff9fb5b4eac00344e457b61797745638107 SHA512 8e7afefd8f0654340e234f7bd1cc3684b3e5d1f4d94d17c79ed8fb82096c21a809e7f8db2fea9509d45c3f2bdc5e8ed52fb0823779b0a039f87528642803725b
+DIST django-taggit-2.0.0.tar.gz 55042 BLAKE2B cb4d3c8b32ba524eb0c59b447155b818c30ed77ec95a76c7412bccf109d421f2628fb40c8bb65d2c845351c8e8ed77605c0e5d77ac1ddcff6cddd5248f2fcdc6 SHA512 9cffde5a0de170e08ff93b245873b02a4868e67ea946c6b9997b782fecb8f71418dddc702ca283d45e8c1685a4a45143aa6c726de187410b9a89afe2efadd190
diff --git a/dev-python/django-taggit/django-taggit-2.0.0.ebuild b/dev-python/django-taggit/django-taggit-2.0.0.ebuild
new file mode 100644
index 000000000000..f96c6d6a8907
--- /dev/null
+++ b/dev-python/django-taggit/django-taggit-2.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Simple tagging for Django"
+HOMEPAGE="https://github.com/jazzband/django-taggit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ dev-python/djangorestframework[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ "${EPYTHON}" -m django test -v 2 --settings=tests.settings ||
+ die "Tests failed with ${EPYTHON}"
+}