summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-12 06:29:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-12 06:29:42 +0200
commitd4bec0730dcf9719f843f7048707c800bbbbfc4a (patch)
tree664a3269ebfebd6caaefddf895dd09d900b35086 /dev-python/docstring-to-markdown
parentdev-util/stripe-mock: Bump to 0.176.0 (diff)
downloadgentoo-d4bec0730dcf9719f843f7048707c800bbbbfc4a.tar.gz
gentoo-d4bec0730dcf9719f843f7048707c800bbbbfc4a.tar.bz2
gentoo-d4bec0730dcf9719f843f7048707c800bbbbfc4a.zip
dev-python/docstring-to-markdown: Bump to 0.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/docstring-to-markdown')
-rw-r--r--dev-python/docstring-to-markdown/Manifest1
-rw-r--r--dev-python/docstring-to-markdown/docstring-to-markdown-0.13.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/docstring-to-markdown/Manifest b/dev-python/docstring-to-markdown/Manifest
index c6d821be5c48..9a9028ff0265 100644
--- a/dev-python/docstring-to-markdown/Manifest
+++ b/dev-python/docstring-to-markdown/Manifest
@@ -1 +1,2 @@
DIST docstring-to-markdown-0.12.gh.tar.gz 25464 BLAKE2B bb5168b9ddd14f2da63577e302b9c7ec016abcbbfbd1653a22ed646f6980fb4e6d0994a9aa4a6c28f0955cb60d581f2d2e216ab731ae405b3c02d0f14e8fe82f SHA512 ac958cca518164406feff07f665d6edc6113d547393ff28d29a64b8b3f1bae306255ebf859f3e5f1fc75fabea985e1dd24d47c32766403b6ffabf9c31ff7ba45
+DIST docstring-to-markdown-0.13.gh.tar.gz 27375 BLAKE2B db68b5c90ef46a765baa41b5d3e286008cea3602d397d246c7ae3907afabf387c2b551affa3f39102fb0d2ca1479126051f49163918fa5c1cfa503ba6c40c107 SHA512 adaeff9c9c4359889757e80d91cbca1c85c6aa888b66824802828d247c09919877e416367f7334db5c944312b3c3468256c159e598c837718806f314aa11b8db
diff --git a/dev-python/docstring-to-markdown/docstring-to-markdown-0.13.ebuild b/dev-python/docstring-to-markdown/docstring-to-markdown-0.13.ebuild
new file mode 100644
index 000000000000..e38895f600bf
--- /dev/null
+++ b/dev-python/docstring-to-markdown/docstring-to-markdown-0.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="On the fly conversion of Python docstrings to markdown"
+HOMEPAGE="
+ https://github.com/python-lsp/docstring-to-markdown/
+ https://pypi.org/project/docstring-to-markdown/
+"
+SRC_URI="
+ https://github.com/python-lsp/docstring-to-markdown/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not depend on pytest-cov/pytest-flake8
+ sed -e '/--cov/d' -e '/--flake8/d' -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}