summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-20 07:09:41 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-20 07:38:22 +0200
commit59c1132842ae7a907e32f6a50912e3ab13f7f052 (patch)
treedd89d76a745c7e17fb8e5fc3c6fc4fd3470289ec /dev-python/fakeredis
parentnet-misc/electrum: Bump to 4.4.5 (diff)
downloadgentoo-59c1132842ae7a907e32f6a50912e3ab13f7f052.tar.gz
gentoo-59c1132842ae7a907e32f6a50912e3ab13f7f052.tar.bz2
gentoo-59c1132842ae7a907e32f6a50912e3ab13f7f052.zip
dev-python/fakeredis: Bump to 2.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fakeredis')
-rw-r--r--dev-python/fakeredis/Manifest1
-rw-r--r--dev-python/fakeredis/fakeredis-2.15.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index b403bc1cd86b..30f19d74366a 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -2,3 +2,4 @@ DIST fakeredis-2.12.1.tar.gz 97486 BLAKE2B 5207d9b946eb5720083b045e29b960cc2eb3a
DIST fakeredis-2.13.0.tar.gz 98084 BLAKE2B c147332f2575be7f63aef48199920480d550efbadeee9de255b17cb9c7d6791a059ee3d4bdc500ecf44dcc22de6fdd11d170daf3e19de8e910833b1de12232c6 SHA512 30335e456f7ac2498fc175f9fd154a766064a05e6eb996df9d533412525a3d4279c9359ac5e43a2b9ec9bb1d653639aa10d4e1765a4e4c1bc84f764fa1efdb42
DIST fakeredis-2.14.0.tar.gz 101919 BLAKE2B 7582b3986bc7102a02a69a321e539dc15d425d918397e896eed9d544816697c55e938511ae69201eae3a5c1e814afe7f0c472d48a249be976178a7c0279472ae SHA512 a63b46420d9ca2348b0ed0f4ef2c0227a4dbc46efef2fae5beae2513cc77732be830669910f14d59ecb2f1fa3b698e29855658239fea4ff458c4ba62fd9fa4cb
DIST fakeredis-2.14.1.tar.gz 101789 BLAKE2B 2e38319aa8bb23c9cd2196d8dbcf489fead785bffa3b464b7e420f28b247c911ea9f3775328f8fec7c26b1a77e32d6a21acf627fe7b603f311b0f3820fa06b54 SHA512 71b7f034ad5ccdd569052a82d2e15ec21db4b5a26bc5c660f76bb88c0b7aaa252234e899644dfd63086aaf8a9400ea13acc6439fdca08f84c8392949815f33d2
+DIST fakeredis-2.15.0.tar.gz 108160 BLAKE2B aaf135ffc395d6304c2f95b0339610f506382e865039f647a9af3fd9e3fa8cd9b9f6ea6557670fd61e949136f35de10b0fad63a1813d59f5b3697dd200195960 SHA512 59bc74a328b85cebcf0ae61d70e4ce26f3cdde3b82de6746f6b33229a6185d542db1e2ddd7c8ea600db69a6c630dbf81998ba108982da33487fe5ad2068abb29
diff --git a/dev-python/fakeredis/fakeredis-2.15.0.ebuild b/dev-python/fakeredis/fakeredis-2.15.0.ebuild
new file mode 100644
index 000000000000..10e805e1986c
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-2.15.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/cunla/fakeredis-py/
+ https://pypi.org/project/fakeredis/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.2[${PYTHON_USEDEP}]
+ <dev-python/sortedcontainers-3[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # also lupa
+ test/test_aioredis2.py::test_failed_script_error
+ # TODO
+ "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
+ "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_channels[StrictRedis]"
+ test/test_mixins/test_set_commands.py::test_smismember_wrong_type
+ )
+ local EPYTEST_IGNORE=(
+ # these tests fail a lot...
+ test/test_hypothesis.py
+ )
+ local args=(
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+ epytest "${args[@]}"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}