summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-09 09:55:39 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-09 10:33:03 +0100
commiteb3d358bee104b8b5be885718e22f0ddf47e86e3 (patch)
tree1a6cb119277bc77b7a87ab55a1f774ced93f44f2 /dev-python/flake8
parentdev-python/debtcollector: Add python3.5 support (diff)
downloadgentoo-eb3d358bee104b8b5be885718e22f0ddf47e86e3.tar.gz
gentoo-eb3d358bee104b8b5be885718e22f0ddf47e86e3.tar.bz2
gentoo-eb3d358bee104b8b5be885718e22f0ddf47e86e3.zip
dev-python/flake8: Add python3.5 support
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/flake8-2.0-r1.ebuild4
-rw-r--r--dev-python/flake8/flake8-2.1.0.ebuild4
-rw-r--r--dev-python/flake8/flake8-2.2.5.ebuild5
-rw-r--r--dev-python/flake8/flake8-2.5.1.ebuild16
4 files changed, 17 insertions, 12 deletions
diff --git a/dev-python/flake8/flake8-2.0-r1.ebuild b/dev-python/flake8/flake8-2.0-r1.ebuild
index a226f0360954..5bace8141683 100644
--- a/dev-python/flake8/flake8-2.0-r1.ebuild
+++ b/dev-python/flake8/flake8-2.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
inherit distutils-r1
diff --git a/dev-python/flake8/flake8-2.1.0.ebuild b/dev-python/flake8/flake8-2.1.0.ebuild
index cac92f3bc683..c48c2dc5c03d 100644
--- a/dev-python/flake8/flake8-2.1.0.ebuild
+++ b/dev-python/flake8/flake8-2.1.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
inherit distutils-r1
diff --git a/dev-python/flake8/flake8-2.2.5.ebuild b/dev-python/flake8/flake8-2.2.5.ebuild
index d352fa04c513..6a49a2d13ba4 100644
--- a/dev-python/flake8/flake8-2.2.5.ebuild
+++ b/dev-python/flake8/flake8-2.2.5.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
inherit distutils-r1
diff --git a/dev-python/flake8/flake8-2.5.1.ebuild b/dev-python/flake8/flake8-2.5.1.ebuild
index 1393f6c4e0c2..4a5fc3b8bf33 100644
--- a/dev-python/flake8/flake8-2.5.1.ebuild
+++ b/dev-python/flake8/flake8-2.5.1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
inherit distutils-r1
@@ -17,19 +18,22 @@ LICENSE="MIT"
SLOT="0"
# requires.txt inc. mccabe however that creates a circular dep
-RDEPEND=">=dev-python/pyflakes-0.8.1[${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-python/pyflakes-0.8.1[${PYTHON_USEDEP}]
<dev-python/pyflakes-1.1[${PYTHON_USEDEP}]
>=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
!=dev-python/pep8-1.6.1[${PYTHON_USEDEP}]
!=dev-python/pep8-1.6.2[${PYTHON_USEDEP}]
"
-PDEPEND=">=dev-python/mccabe-0.2.1[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.4[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${PDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ )"
+PDEPEND="
+ >=dev-python/mccabe-0.2.1[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.4[${PYTHON_USEDEP}]"
python_prepare_all() {
# This tests requires / assumes this version is already installed.