summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-22 19:50:38 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-22 19:50:47 +0300
commit466aabbafd2a31526b48ebbf1bb906c039dde4a4 (patch)
tree22ae94ca32b4a491c4d0137b9b5c8c54b219d2c4 /dev-python/fonttools
parentdev-python/zope-testing: Add a blocker on namespace-zope (diff)
downloadgentoo-466aabbafd2a31526b48ebbf1bb906c039dde4a4.tar.gz
gentoo-466aabbafd2a31526b48ebbf1bb906c039dde4a4.tar.bz2
gentoo-466aabbafd2a31526b48ebbf1bb906c039dde4a4.zip
dev-python/fonttools: add 4.33.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.33.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 7ea2267a9902..abe838319248 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -3,3 +3,4 @@ DIST fonttools-4.31.1.tar.gz 2964489 BLAKE2B d1bb7059383785dd527f7276ef876042f81
DIST fonttools-4.31.2.tar.gz 2965796 BLAKE2B d776073e7a9358e67b8753dd4557e2b1b4c44d9662c8c728abe42d970bca1db1789a655df8865fef39eed3a32271749d2cb772e306f34efc87e737b7384c0b5d SHA512 50cc8bca9136675a413ac947b583f694d512872127cee129a78505d0259fe1cf6922f806558761af982758f72c7d95e1245b8de55b6ebd6ddd3bd7506d41abcf
DIST fonttools-4.32.0.tar.gz 2966840 BLAKE2B 67a79c8c2e26f9f72fcf6ea4ab5ee3712d3541b47528a209221f9fcf82a5b5db589561200e4b6911a32102a4f4dc4b4e34c8271eb97b1cee18a81b3039efdf03 SHA512 a71a44601c7ec9f709ddc14da1c26d1248909fba8a0bfb7104ebe5f9b85949fe479c5eabdd2c94086d9999756035291e68bb7e861488d4123ccf667ac3ac2e03
DIST fonttools-4.33.0.tar.gz 3525052 BLAKE2B 5ea275adbfbf6e01222f6eba8f5eef7afe533b9692e6a7a2fb644fb68dec632ab2962d6b7f6b4ff876676e8314aadbfc04a005ea7a389904e398723feaa756d0 SHA512 147f6d41d1a6b27ebe6973cb91a90384291ad8c7b75b71c3b814908012530066b79f4c39bdd6da9e98614ef61b1cc19803756aba73e4da7ce2e82147390f0023
+DIST fonttools-4.33.1.tar.gz 3526591 BLAKE2B c720e9159602168bc2f435f96e9b470e95a748e3e61aac717659e01e5998c8ead825056fe6114cb40be47ab1ebcd7dc6f3152cccd87aec5b49134147694aa3eb SHA512 14e4da0e146d4b88ab6375ad7c912f1ec6f437386e2d676bbffcd5a84be980151ed4f77f69bf618843b321106ca763af564cf05dfb6fa11888f02adfde7d74b2
diff --git a/dev-python/fonttools/fonttools-4.33.1.ebuild b/dev-python/fonttools/fonttools-4.33.1.ebuild
new file mode 100644
index 000000000000..f0532d0a8742
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.33.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/fonttools/fonttools/"
+SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND=">=dev-python/fs-2.4.9[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ export FONTTOOLS_WITH_CYTHON=1
+}
+
+src_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ epytest Tests fontTools || die "Tests failed with ${EPYTHON}"
+}