summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-19 06:10:01 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-19 06:16:57 +0200
commit7618afd343f980b392bea2296b9b13a23c5b179e (patch)
tree69c5e49468a0c33e30312571836273711e4e41ea /dev-python/furo
parentdev-python/pyaml: Bump to 24.7.0 (diff)
downloadgentoo-7618afd343f980b392bea2296b9b13a23c5b179e.tar.gz
gentoo-7618afd343f980b392bea2296b9b13a23c5b179e.tar.bz2
gentoo-7618afd343f980b392bea2296b9b13a23c5b179e.zip
dev-python/furo: Bump to 2024.7.18
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/furo')
-rw-r--r--dev-python/furo/Manifest1
-rw-r--r--dev-python/furo/furo-2024.7.18.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/furo/Manifest b/dev-python/furo/Manifest
index 1fb117f9f491..e0b47e55e011 100644
--- a/dev-python/furo/Manifest
+++ b/dev-python/furo/Manifest
@@ -1 +1,2 @@
DIST furo-2024.5.6-py3-none-any.whl 341199 BLAKE2B 6cecc3407bb91f096ba755d2d36f8e165dd8887f513495013533907017248c8a1f15d8019d5b4d5e7acd2793d95dc82cf95fc5ca1d9ad42bdcc57983d451db97 SHA512 932336ddff321b5dcdf98ee6aeda2cd33ce7981fb3f74fad5c2c732ff7d5be9c8666dd89808630a24b7d610965f8921ad477e9409ba5c2b9ad112d338dd06629
+DIST furo-2024.7.18-py3-none-any.whl 340824 BLAKE2B 619e7183541921ec31f5a7e7ebcbc86f0507e04bf7e5c9e308a3b6a6b580cf734fe46b641b3bcaaeeaba39516ca27b49ef8faadd0d9d5864343aafc15a05037d SHA512 62c047742a0a851e5faf56013751d05a411920ca7659ef42fc06bcce6766a6605734b370a636f4b1c2805def42881c273a2b5eb6704484571d76a44145b0a346
diff --git a/dev-python/furo/furo-2024.7.18.ebuild b/dev-python/furo/furo-2024.7.18.ebuild
new file mode 100644
index 000000000000..9afc06b408f3
--- /dev/null
+++ b/dev-python/furo/furo-2024.7.18.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# sphinx-theme-builder is completely unusable, as it requires pinning
+# to a very-specific nodejs version number, and ofc loves fetching
+# everything from the Internet
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Clean customisable Sphinx documentation theme"
+HOMEPAGE="
+ https://pypi.org/project/furo/
+ https://github.com/pradyunsg/furo/
+"
+SRC_URI="$(pypi_wheel_url)"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-basic-ng[${PYTHON_USEDEP}]
+"
+
+src_unpack() {
+ if [[ ${PKGBUMPING} == ${PVR} ]]; then
+ unzip "${DISTDIR}/${A}" || die
+ fi
+}
+
+python_compile() {
+ distutils_wheel_install "${BUILD_DIR}/install" \
+ "${DISTDIR}/${P}-py3-none-any.whl"
+}