summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-12-29 01:09:36 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-12-29 07:01:27 +0000
commit94986c3b7151d2c96bf979c6f9368201edcacbde (patch)
treeaf063fac620aea10d7f242ad2a3f700b2be73851 /dev-python/ginga
parentdev-python/naima: version bump (diff)
downloadgentoo-94986c3b7151d2c96bf979c6f9368201edcacbde.tar.gz
gentoo-94986c3b7151d2c96bf979c6f9368201edcacbde.tar.bz2
gentoo-94986c3b7151d2c96bf979c6f9368201edcacbde.zip
dev-python/ginga: version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/ginga')
-rw-r--r--dev-python/ginga/Manifest1
-rw-r--r--dev-python/ginga/ginga-2.6.1.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/ginga/Manifest b/dev-python/ginga/Manifest
index d3557700e2ca..93b58a89f0c4 100644
--- a/dev-python/ginga/Manifest
+++ b/dev-python/ginga/Manifest
@@ -1 +1,2 @@
DIST ginga-2.6.0.tar.gz 12682426 SHA256 ae4661cc2438cafcd66281172776e6968255482d122a154030bc815c19e0afd4 SHA512 b07fc8a20f17173682bfce5190200f3080dff12fae73e06e1447ebdfe1dc98362e03bd2ed5c524fce0ffcd15e3b74170c97a74222f7601f25e9e5bf0bd93148a WHIRLPOOL 430f9e0585f1b4546400ca9ba89eda1a81d88fd62ebade5d907d069f3f19e6155d7b7c8bdaa9186ba306873a1d41f7cfb64ed5f2262a96eb1c5e06f4a1027d82
+DIST ginga-2.6.1.tar.gz 12693626 SHA256 5087f1213a0aa2fffdc3d81a258d1a4662f92894f532843ba2c83ba237363116 SHA512 f12bc41de0f6efb39096f1175a7d94659135230fc2d024ac0532f09e39d1d674cbce28ce073c37e8cbff19db9b8d0fe6c40ee829a4ba38ad276b39ab6765c5a9 WHIRLPOOL ada7e2174ba401581d70b88301f145e6ba348aec71271eac982056ce3c20fb8c1dcfa31200506a5bb6183777708df5ee57a2ccb50f2732ea90a20c864aea6683
diff --git a/dev-python/ginga/ginga-2.6.1.ebuild b/dev-python/ginga/ginga-2.6.1.ebuild
new file mode 100644
index 000000000000..249b5fa5fc74
--- /dev/null
+++ b/dev-python/ginga/ginga-2.6.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5} )
+PYTHON_REQ_USE='tk?'
+
+inherit distutils-r1 eutils fdo-mime
+
+DESCRIPTION="Astronomical image toolkit for Python"
+HOMEPAGE="https://ejeschke.github.io/ginga"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc examples gtk qt4 qt5 test tk"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ media-fonts/roboto
+ gtk? ( dev-python/pygobject[${PYTHON_USEDEP},cairo] )
+ qt4? ( || (
+ dev-python/pyside[${PYTHON_USEDEP},help,X]
+ dev-python/PyQt4[${PYTHON_USEDEP},help,X]
+ ) )
+ qt5? ( dev-python/PyQt5[${PYTHON_USEDEP},help,gui,widgets] )"
+
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-no-roboto.patch )
+
+python_prepare_all() {
+ # use system astropy-helpers instead of bundled one
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ PYTHONPATH="${BUILD_DIR}"/lib esetup.py build_sphinx --no-intersphinx
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+ rm -r "${ED%/}"/usr/lib*/*/*/ginga/examples || die
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r ginga/examples
+ fi
+ domenu ginga.desktop
+}
+
+pkg_postinst() {
+ optfeature "Pick, Cuts, Histogram, LineProfile" \
+ dev-python/matplotlib sci-libs/scipy
+ optfeature "Online help browser" dev-qt/qtwebkit
+ optfeature "To save a movie" media-video/mplayer
+ optfeature "Speeds up rotation and some transformations" \
+ dev-python/numexpr dev-python/opencv dev-python/pyopencl
+ optfeature "Aids in identifying files when opening them" \
+ dev-python/filemagic
+ optfeature "Useful for various RGB file manipulations" dev-python/pillow
+
+ # Update mimedb for the new .desktop file
+ fdo-mime_desktop_database_update
+}