summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-12-28 21:25:26 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-12-28 21:26:34 -0600
commitb364000bbbd6eaa5cf546dd4020a3a3b7e62b0ff (patch)
treea9000626fff3a984b0d3f8b7fbf64dfb1897538d /dev-python/git-review
parentapp-text/asciidoc: drop USE=test from 10.1.1 (diff)
downloadgentoo-b364000bbbd6eaa5cf546dd4020a3a3b7e62b0ff.tar.gz
gentoo-b364000bbbd6eaa5cf546dd4020a3a3b7e62b0ff.tar.bz2
gentoo-b364000bbbd6eaa5cf546dd4020a3a3b7e62b0ff.zip
dev-python/git-review: 9999 bump for git 2.18 fix
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/git-review')
-rw-r--r--dev-python/git-review/git-review-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/git-review/git-review-9999.ebuild b/dev-python/git-review/git-review-9999.ebuild
new file mode 100644
index 000000000000..bd9c8e269e6b
--- /dev/null
+++ b/dev-python/git-review/git-review-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
+DISTUTILS_USE_SETUPTOOLS=
+
+inherit distutils-r1
+
+DESCRIPTION="Tool to submit code to Gerrit"
+HOMEPAGE="https://git.openstack.org/cgit/openstack-infra/git-review"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/opendev/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-python/pbr-4.1.0[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/requests-1.1[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i -e '/manpages/,+1d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}