summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-10 03:36:26 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-10 03:43:56 +0200
commitd53672bbfcfd009f55bce1046eb3ad86bc536d86 (patch)
tree7c12c6329277211838bded6e4222dd23a4b45181 /dev-python/griffe
parentapp-arch/stormlib: Remove old (diff)
downloadgentoo-d53672bbfcfd009f55bce1046eb3ad86bc536d86.tar.gz
gentoo-d53672bbfcfd009f55bce1046eb3ad86bc536d86.tar.bz2
gentoo-d53672bbfcfd009f55bce1046eb3ad86bc536d86.zip
dev-python/griffe: Bump to 0.45.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/griffe')
-rw-r--r--dev-python/griffe/Manifest1
-rw-r--r--dev-python/griffe/griffe-0.45.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/griffe/Manifest b/dev-python/griffe/Manifest
index e8f8f9b6013f..10d707f443de 100644
--- a/dev-python/griffe/Manifest
+++ b/dev-python/griffe/Manifest
@@ -1 +1,2 @@
DIST griffe-0.45.2.gh.tar.gz 230750 BLAKE2B f81d62232bc4812c68130dc8a060541f143a7762f0e3c9051731f376a61926b7bd3bd32bd7e00d03c5eaa5eeab49c42d29a8045ddd9594f6637f5814c9ce37da SHA512 d77709281e669eef88fa4c3190f74c862b2de4a9e3b3d0b6bfe6e9df8a608b5dbd92dacf118ffbad98948dc27e190506e9527f994a398fdc635a47fbe5470050
+DIST griffe-0.45.3.gh.tar.gz 228938 BLAKE2B fa6ea0e5aca0e7124671ccf0527f78f46be3462bac8656fb7b6ba3bf715956418477e28ba27af57c42fea4b60eabb6125e308d189c24388484c2b5e48bf2bccc SHA512 c40dac16fe7993b790be6ff1bf23aa79a84985eeeb772fae96121b625efc80d7c7d7a77aac9077997a63880b50f59ac493d1da8392ddaefd3f95fe8eda5af985
diff --git a/dev-python/griffe/griffe-0.45.3.ebuild b/dev-python/griffe/griffe-0.45.3.ebuild
new file mode 100644
index 000000000000..482500b13259
--- /dev/null
+++ b/dev-python/griffe/griffe-0.45.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Signature generator for Python programs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/griffe/
+ https://github.com/mkdocstrings/griffe/
+ https://pypi.org/project/griffe/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/griffe/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/jsonschema-4.17[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # fragile to installed packages
+ # (failed on PySide2 for me)
+ tests/test_stdlib.py::test_fuzzing_on_stdlib
+)