summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-26 12:46:11 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-26 13:05:38 +0200
commit69a5d4b1f4a39e2397d13b5500285d3188f2d365 (patch)
tree057a469d683ea83c570ab125b5a6ce012a5638ed /dev-python/h11
parentdev-python/path-py: Bump to 16.5.0 (diff)
downloadgentoo-69a5d4b1f4a39e2397d13b5500285d3188f2d365.tar.gz
gentoo-69a5d4b1f4a39e2397d13b5500285d3188f2d365.tar.bz2
gentoo-69a5d4b1f4a39e2397d13b5500285d3188f2d365.zip
dev-python/h11: Bump to 0.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/h11')
-rw-r--r--dev-python/h11/Manifest1
-rw-r--r--dev-python/h11/h11-0.14.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/h11/Manifest b/dev-python/h11/Manifest
index eb8286a51cd4..7ab504667b28 100644
--- a/dev-python/h11/Manifest
+++ b/dev-python/h11/Manifest
@@ -1 +1,2 @@
DIST h11-0.13.0.tar.gz 100165 BLAKE2B 6cb610afa474f5945151300e6ec6c2860e8b959b9ab0224b58fb047f3fa0b417499adb0119b7b7727b9ebfb4b60360fef78843fde41935616784bbf450605503 SHA512 c3a16dd66287ab6491b664aab9d72e14f1e61950c19182d60e195b81b2857e47157c38137b2ee2a9cd35d9d54997f554f768a3933051030895ddf7bc5b813e02
+DIST h11-0.14.0.tar.gz 100418 BLAKE2B 09f0dfe4e1d3d117f772ec914cddb4af5c09f07269e0b148f78d95b3b177cb9c69f6406c518ec0ad81ef960c199749317141e50c38cdeee0faf24e1f9333ab27 SHA512 6146f6441ce62ea46d824a86c1687401224ea6084ca2703b9c841dce51cdfb5de49b39a4f4a7e95efae40ed83012ea4a8641700281f728c2f580a90ce42d82a5
diff --git a/dev-python/h11/h11-0.14.0.ebuild b/dev-python/h11/h11-0.14.0.ebuild
new file mode 100644
index 000000000000..592e6d017437
--- /dev/null
+++ b/dev-python/h11/h11-0.14.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python implementation of HTTP/1.1 inspired by hyper-h2"
+HOMEPAGE="
+ https://h11.readthedocs.io/en/latest/
+ https://github.com/python-hyper/h11/
+ https://pypi.org/project/h11/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest