summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-05 06:00:27 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-05 06:00:57 +0100
commitea3e8518ea0090baea22d23ed7e90c7b63f18861 (patch)
tree624e8575fbb03718dd60e1ea50310a20f656562e /dev-python/hiredis
parentdev-python/django: Bump to 4.2.17 (diff)
downloadgentoo-ea3e8518ea0090baea22d23ed7e90c7b63f18861.tar.gz
gentoo-ea3e8518ea0090baea22d23ed7e90c7b63f18861.tar.bz2
gentoo-ea3e8518ea0090baea22d23ed7e90c7b63f18861.zip
dev-python/hiredis: Bump to 3.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hiredis')
-rw-r--r--dev-python/hiredis/Manifest1
-rw-r--r--dev-python/hiredis/hiredis-3.1.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/hiredis/Manifest b/dev-python/hiredis/Manifest
index dbb9d4231330..3012822f6354 100644
--- a/dev-python/hiredis/Manifest
+++ b/dev-python/hiredis/Manifest
@@ -1 +1,2 @@
DIST hiredis-py-3.0.0.gh.tar.gz 19055 BLAKE2B 2ad3c185b6a70ebb509e0d34b1a1122784c74ecc843c966620a20d122e05dcb11129dbb7f76a7956081d147881edc2c66264fda1109e6990ef2171f15b339da7 SHA512 64abc15f73eaf65e16b1c3f98c21cf31823ffeb7131b89eeefee9856654c016867903d9a5d8c7ab0bdb24922076a67cb553c4298abcccd69ad0d5ba2d18c8a67
+DIST hiredis-py-3.1.0.gh.tar.gz 19066 BLAKE2B 06b4c3e47a27d16b28a96f0769399d8b3bcc361ac14d755134cb88faed4e403e89892276a3ce5e7c2920b45c5575caba8777cef8d64bc61fcf9d47f1b94b19f2 SHA512 8c47179bc55b89d64aa02a18c81d0e77669882afe126ca7ca468df8c9417023c36c6e3bdfcc28e092feba7a766655005e839a3aaf766d2fc4424176808c978d8
diff --git a/dev-python/hiredis/hiredis-3.1.0.ebuild b/dev-python/hiredis/hiredis-3.1.0.ebuild
new file mode 100644
index 000000000000..a7183e750350
--- /dev/null
+++ b/dev-python/hiredis/hiredis-3.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+MY_P=hiredis-py-${PV}
+DESCRIPTION="Python extension that wraps hiredis"
+HOMEPAGE="
+ https://github.com/redis/hiredis-py/
+ https://pypi.org/project/hiredis/
+"
+SRC_URI="
+ https://github.com/redis/hiredis-py/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/hiredis-1.0.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/hiredis-2.4.0-system-libs.patch
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ rm -rf hiredis || die
+ epytest
+}