summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-04-12 14:56:04 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-04-12 18:55:25 +0000
commitbaba4be200e6de1dfe15173cfb8404d734e6d4a3 (patch)
tree7af139059cc8de1e35b3c7bb0eb64feaf9001218 /dev-python/httpauth/httpauth-0.3.ebuild
parentmail-client/mutt: add elog about changed option names for sidebar (diff)
downloadgentoo-baba4be200e6de1dfe15173cfb8404d734e6d4a3.tar.gz
gentoo-baba4be200e6de1dfe15173cfb8404d734e6d4a3.tar.bz2
gentoo-baba4be200e6de1dfe15173cfb8404d734e6d4a3.zip
dev-python/httpauth: new package, needed for www-apps/klaus
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1248 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/httpauth/httpauth-0.3.ebuild')
-rw-r--r--dev-python/httpauth/httpauth-0.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/httpauth/httpauth-0.3.ebuild b/dev-python/httpauth/httpauth-0.3.ebuild
new file mode 100644
index 000000000000..c47eb0ce4662
--- /dev/null
+++ b/dev-python/httpauth/httpauth-0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI middleware that secures routes using HTTP Digest Authentication"
+HOMEPAGE="https://github.com/jonashaag/httpauth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ nosetests tests.py || die "tests failed with ${EPYTHON}"
+}