summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-29 22:50:44 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-29 23:28:48 +0100
commit2a85832999c417bb8e825b758323ffc8a3864afa (patch)
tree264dd43e192a3b0ee31ef995e5790f3279e3abeb /dev-python/humanize
parentdev-python/Faker: Bump to 9.8.4 (diff)
downloadgentoo-2a85832999c417bb8e825b758323ffc8a3864afa.tar.gz
gentoo-2a85832999c417bb8e825b758323ffc8a3864afa.tar.bz2
gentoo-2a85832999c417bb8e825b758323ffc8a3864afa.zip
dev-python/humanize: Bump to 3.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-3.13.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 090530e513e8..ec8f139202d5 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1,2 +1,3 @@
DIST humanize-3.11.0.tar.gz 67034 BLAKE2B 9e10582139578e8e041d1ce60c9c5d7e071c4c093a64cf620df6ff38f0567e8b2f3134f10722cb724d13343373db0fa2a1ae5bd68700ff85fb58ee318feb0fd0 SHA512 7aa3c513c6702de0e099865f787858de4c9c65cfe95af61fd0204ff6df64e7359474b4067b4672546936beae6c8c512dd9c75f555d7075c94819e81143c21ce9
DIST humanize-3.12.0.tar.gz 67112 BLAKE2B 248458d337c8411261b1078b3ebc040c133bd6310d89ac6809e36e55b46c644ab1308255015e9530c0b1d5d5a0c6ba3b02fbdcb8a48f48c02802ec8314c68210 SHA512 339cd392c9fd022714dfa54920b24522eee37ec24711fea8016f6a95728a500eaf9cc4dde76e542886f6c5b570a77beeb6dbc5047a475496f99199d793ab2e44
+DIST humanize-3.13.0.tar.gz 71972 BLAKE2B 9c9d2198de70a0cbdbb7ad7d161778870e4464df04c9e03fd18c71f4109f8dc6bc5c41545ccb82027a59fcde6d3e6fa66251b03bad63bc0200bab6b58412b391 SHA512 02baccf184dcc075839275de552f37ef13afd3412338a67ef52167622b0bf06e8c19f8d49796674e435947c4644d614bb362addea8660d10e5884cd6711ea2e1
diff --git a/dev-python/humanize/humanize-3.13.0.ebuild b/dev-python/humanize/humanize-3.13.0.ebuild
new file mode 100644
index 000000000000..bc06c827f367
--- /dev/null
+++ b/dev-python/humanize/humanize-3.13.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests --install pytest