summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-28 06:49:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-28 06:49:03 +0200
commit37411081fcfdf1d8162344e6cb6b16f1577d79b3 (patch)
tree0ad1f1dd419e1641d85194fb8f3f7981f3b60f07 /dev-python/humanize
parentdev-python/ConfigArgParse: Bump to 1.5.5 (diff)
downloadgentoo-37411081fcfdf1d8162344e6cb6b16f1577d79b3.tar.gz
gentoo-37411081fcfdf1d8162344e6cb6b16f1577d79b3.tar.bz2
gentoo-37411081fcfdf1d8162344e6cb6b16f1577d79b3.zip
dev-python/humanize: Bump to 4.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-4.7.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index cfc432ba645d..ed8188ba0c45 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1 +1,2 @@
DIST humanize-4.6.0.tar.gz 69815 BLAKE2B e32195b87080598ee0d024526c2631e9498c0019e344a2b3babbfea657a4d36611cb53e74e33634f26fa184fa1526ee700253b4f6a48b241a231b794669f31f0 SHA512 3c003d645d33b4d31ffa5a63b8754b939579a6ed396cd285789f9bd17e750147c425d41adb424af45d69844c6e2b9be8fed04f388f017f25c6eda1f31c053b3e
+DIST humanize-4.7.0.tar.gz 72028 BLAKE2B 86926d24ca20168cd1f5dc37aad38a53be59ab786bd02c25ba54930854b4459949bfa988f3135c97f15cc51b2b9fcdcb32f85a668ddbb4af2b571d974523cc12 SHA512 2454c4b7dec6868a1626af560e4f87d7bfb8eac6a919c7d7c03254723ec58494f104f7fa365c64cb4cecf50cd6d498b4201f9fda6ac1f6d2980e9e54eebde738
diff --git a/dev-python/humanize/humanize-4.7.0.ebuild b/dev-python/humanize/humanize-4.7.0.ebuild
new file mode 100644
index 000000000000..681e01638c1b
--- /dev/null
+++ b/dev-python/humanize/humanize-4.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="
+ https://github.com/python-humanize/humanize/
+ https://pypi.org/project/humanize/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest