summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-30 21:19:44 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-30 21:20:25 +0200
commita9cfc885e32b49f962b142183d76836e596b90e0 (patch)
tree931f290880d5d1bafd4ee64b712420d5be698b4f /dev-python/humanize
parentnet-print/hplip: Remove old hplip-3.20.6-r2. (diff)
downloadgentoo-a9cfc885e32b49f962b142183d76836e596b90e0.tar.gz
gentoo-a9cfc885e32b49f962b142183d76836e596b90e0.tar.bz2
gentoo-a9cfc885e32b49f962b142183d76836e596b90e0.zip
dev-python/humanize: bump to 3.0.0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-3.0.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index deb145f01f9d..2645843bb497 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1 +1,2 @@
DIST humanize-2.6.0.tar.gz 53753 BLAKE2B 7908100cde103846554264df887ddb54223900cdbf1e52b2a19f029084b2997ab7a02e275f437d0cc04c3c42d6f8c371fbdab23468cdeb8f98a8cd6a64c1c288 SHA512 d1e57672c80ccabc48dadb2bafe65ac0b5b23de13907d7d51a06b6a1f2f01ef254e36afa203c9393420ad3bb5aaa22616a0d5c4c71cc53cf47727436be0b1599
+DIST humanize-3.0.0.tar.gz 53458 BLAKE2B c75ddbeed88aaef0019b50691576e6c8dd8ffdbf0ed1f1d1221c40ebfbaa502176f2db463afea3c8384f1b9acea7daaeca1e81f72919dbe2c476ff9d95db166b SHA512 8d566b4fba6b1f7f025e30d5d0402cb7ef7bf4881fb14608b011474d3e6991a0a058d444ccfdbb796205d959c2c4192e0eb98c6c15c31ba9e304f39a7cf8d025
diff --git a/dev-python/humanize/humanize-3.0.0.ebuild b/dev-python/humanize/humanize-3.0.0.ebuild
new file mode 100644
index 000000000000..94f1f6012cd1
--- /dev/null
+++ b/dev-python/humanize/humanize-3.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # The package uses pkg_resources to determine its version
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}