summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-12 03:43:30 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-12 04:23:43 +0100
commit87ece1f3706d4fa9ce30692bc8ae46eef42a047a (patch)
tree18da2d1bae67c2712875d3ccd8f752b06d1dc648 /dev-python/hypothesis
parentdev-vcs/git-absorb: fix libgit2 dep (diff)
downloadgentoo-87ece1f3706d4fa9ce30692bc8ae46eef42a047a.tar.gz
gentoo-87ece1f3706d4fa9ce30692bc8ae46eef42a047a.tar.bz2
gentoo-87ece1f3706d4fa9ce30692bc8ae46eef42a047a.zip
dev-python/hypothesis: Bump to 6.123.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.123.15.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 7d3deec24877..ce6eb172fcf0 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,3 +1,4 @@
DIST hypothesis-6.123.13.gh.tar.gz 9510548 BLAKE2B d2656c4e76713533eb58f5cbee945bcd66be2ba50bfa1278d7e507214dcb00f067a1ef0e74e2e7240763fc7ceb9f2cd9f2036840850910134f713fe1891a924e SHA512 541172d8ffaa0a8103d7e889042b20426bfa6131c1628bce1131c83509f449b8b20bb448ed867e8a297392421d300b6e8ca8893da9d42cbf84144db705e35b5c
+DIST hypothesis-6.123.15.gh.tar.gz 9507335 BLAKE2B e4e017ecd78f702aaf02efd5df0a87d145d5a4f2650a1136dd03d240f4d0cd13ab56b39b5e863ea984c6d1db3d8124b59d48151923a0f4750726f05d92ab54dd SHA512 432457b4c556e842b7fbc8248ab094798e895e72e9f7e70fe579eca877d9ab8aec1291584eb6383d18784dacc666525f5200ebec2ee52c9a0397aa35f2114d5e
DIST hypothesis-6.123.2.gh.tar.gz 9506171 BLAKE2B a7033cf2b5d56753ce19c5b369889b62d88c86df8254c840341c599dd97f575fc84e73236e701f4303d6141146bdef24f13f8d666f30a578ff80b067976934ba SHA512 d46b3d83a14b629a39f7eb2dcb0915802ee8185b4796ea38d053e44f2e8e4025a053c99a0aea7b4b59442a24fd3600b78d5a19e1f0bbd13e8a2d9f93cdca3df6
DIST hypothesis-6.123.7.gh.tar.gz 9509012 BLAKE2B 71def0634aee97b4d64bacf9b4a09e091fb209c9de2d2ecbcbb86ad0f7bc2e330e7d7b93e1c810b864fd80ecd82eb6bf51aaf6a6de99c74c338609062ce1e90e SHA512 00b26f4e040a948aaf64554ee395fad4c9b0bb116c87d97bd3ef20be1d25068a79ed1c856c497c1d3d5122481386625c3323be77c0ec851fab823a706350b437
diff --git a/dev-python/hypothesis/hypothesis-6.123.15.ebuild b/dev-python/hypothesis/hypothesis-6.123.15.ebuild
new file mode 100644
index 000000000000..4486f30faf3d
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.123.15.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -p rerunfailures --reruns=5 \
+ tests/cover tests/pytest tests/quality
+}
+
+src_install() {
+ local HAD_CLI=
+
+ distutils-r1_src_install
+
+ if [[ ! ${HAD_CLI} ]]; then
+ rm -r "${ED}/usr/bin" || die
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install
+ if use cli && has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ HAD_CLI=1
+ else
+ rm -r "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}