summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-18 15:47:05 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-18 16:00:46 +0200
commit1d864ccd82f8677007ec2cb5bfb6918026f7ae93 (patch)
tree203b6badd22099795be4b97ec96d5f1198279ce0 /dev-python/icalendar
parentdev-python/xlsxwriter: Bump to 3.1.4 (diff)
downloadgentoo-1d864ccd82f8677007ec2cb5bfb6918026f7ae93.tar.gz
gentoo-1d864ccd82f8677007ec2cb5bfb6918026f7ae93.tar.bz2
gentoo-1d864ccd82f8677007ec2cb5bfb6918026f7ae93.zip
dev-python/icalendar: Bump to 5.0.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/icalendar')
-rw-r--r--dev-python/icalendar/Manifest1
-rw-r--r--dev-python/icalendar/icalendar-5.0.8.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/icalendar/Manifest b/dev-python/icalendar/Manifest
index 65e1d7749d4a..9e152ba6f2b4 100644
--- a/dev-python/icalendar/Manifest
+++ b/dev-python/icalendar/Manifest
@@ -1 +1,2 @@
DIST icalendar-5.0.7.tar.gz 104099 BLAKE2B df45ee6b8c1ad5bfc558195e86e2456aae8f70613724ba16e74093e5454695d8d4ef2e0eb2e312dd2a94c3a12bc6e4febc21174e8380e249f2de906500a1cfc8 SHA512 c541e61d79b76123d119e51ee6d927795a7d675aded427a21bd38d0f069ea454e182a61ff86b96c7769c42560dfc20f7facb00dfe8a9cfa47da74b279d841b42
+DIST icalendar-5.0.8.tar.gz 106954 BLAKE2B 2e6d9cbae1a8feba40c33403e047386dcb8846fb7d8fd9e6b78d2b58ffeb4fb033438f240dd3fa3290f5edeb171a940dc2213cd5d758f59908eea1099807f52d SHA512 275884cf934d8a275dc75346b0518701f2160c43d479e91069f3cad4370b14d9cbc78bf0c1fea287df2da271ec2f71137cfd5ec202d8304df16cf474f7008b53
diff --git a/dev-python/icalendar/icalendar-5.0.8.ebuild b/dev-python/icalendar/icalendar-5.0.8.ebuild
new file mode 100644
index 000000000000..abbe040cb9ee
--- /dev/null
+++ b/dev-python/icalendar/icalendar-5.0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="
+ https://github.com/collective/icalendar/
+ https://pypi.org/project/icalendar/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}