summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-26 07:22:32 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-26 08:03:43 +0200
commit27af22b405a57acb13994cb8fc96b19361715454 (patch)
tree74adebe5ab5288842ec38f6f2f36cbc9e3a74453 /dev-python/indexed-gzip
parentdev-python/pytools: Bump to 2023.1.1 (diff)
downloadgentoo-27af22b405a57acb13994cb8fc96b19361715454.tar.gz
gentoo-27af22b405a57acb13994cb8fc96b19361715454.tar.bz2
gentoo-27af22b405a57acb13994cb8fc96b19361715454.zip
Rename dev-python/{indexed_gzip → indexed-gzip}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/indexed-gzip')
-rw-r--r--dev-python/indexed-gzip/Manifest1
-rw-r--r--dev-python/indexed-gzip/indexed-gzip-1.7.1.ebuild55
-rw-r--r--dev-python/indexed-gzip/metadata.xml19
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/indexed-gzip/Manifest b/dev-python/indexed-gzip/Manifest
new file mode 100644
index 000000000000..b8edd923ebfd
--- /dev/null
+++ b/dev-python/indexed-gzip/Manifest
@@ -0,0 +1 @@
+DIST indexed_gzip-1.7.1.tar.gz 74457 BLAKE2B b22d2120adac59e64f5bcf38c831bb54ce5d6c3dd1e959eece9a454908d9ce2aa5dc10557bd63823616bedfe9d0c039a3f1c0512ef1d22a54437353c57e15158 SHA512 fa27e476f115eca1d1d3892c3480de97cb407bd489737bebc44eb28e92be91e14312cde33a67af145b44c7d93ccc706498c2cbfe6cbff5b9b091dd083cde0f7e
diff --git a/dev-python/indexed-gzip/indexed-gzip-1.7.1.ebuild b/dev-python/indexed-gzip/indexed-gzip-1.7.1.ebuild
new file mode 100644
index 000000000000..44aac738ce10
--- /dev/null
+++ b/dev-python/indexed-gzip/indexed-gzip-1.7.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast random access of gzip files in Python"
+HOMEPAGE="
+ https://pypi.org/project/indexed-gzip/
+ https://github.com/pauldmccarthy/indexed_gzip/
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/zlib:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # strip custom "clean" command that doesn't support "-a"
+ # https://bugs.gentoo.org/838955
+ # TODO: this can be removed once distutils-r1 stops using clean
+ sed -e '/cmdclass/d' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ if use test; then
+ export INDEXED_GZIP_TESTING=1
+ fi
+ distutils-r1_src_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)/indexed_gzip/tests" || die
+ epytest
+}
diff --git a/dev-python/indexed-gzip/metadata.xml b/dev-python/indexed-gzip/metadata.xml
new file mode 100644
index 000000000000..88a3a568d717
--- /dev/null
+++ b/dev-python/indexed-gzip/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ The indexed_gzip project is a Python extension which aims to provide a
+ drop-in replacement for the built-in Python gzip.GzipFile class,
+ the IndexedGzipFile. This package was written to allow fast random
+ access of compressed NIFTI image files (for which GZIP is the de-facto
+ compression standard), but will work with any GZIP file.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">pauldmccarthy/indexed_gzip</remote-id>
+ <remote-id type="pypi">indexed-gzip</remote-id>
+ </upstream>
+</pkgmetadata>