summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-08 08:01:55 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-08 08:07:42 +0200
commit4e4cb8463067bb1b513d3b2fc756bacaf377d4b9 (patch)
tree996f12594223313a441022151235eb1b8fe9fd9a /dev-python/indexed_gzip
parentdev-python/imageio: Remove old (diff)
downloadgentoo-4e4cb8463067bb1b513d3b2fc756bacaf377d4b9.tar.gz
gentoo-4e4cb8463067bb1b513d3b2fc756bacaf377d4b9.tar.bz2
gentoo-4e4cb8463067bb1b513d3b2fc756bacaf377d4b9.zip
dev-python/indexed_gzip: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/indexed_gzip')
-rw-r--r--dev-python/indexed_gzip/Manifest1
-rw-r--r--dev-python/indexed_gzip/indexed_gzip-1.7.0.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/indexed_gzip/Manifest b/dev-python/indexed_gzip/Manifest
index 2cd0d1ba5921..b8edd923ebfd 100644
--- a/dev-python/indexed_gzip/Manifest
+++ b/dev-python/indexed_gzip/Manifest
@@ -1,2 +1 @@
-DIST indexed_gzip-1.7.0.tar.gz 103849 BLAKE2B b33ef1f19e47c2dc12fd6e6fcc972badf4faaecaa5571aa44c765a6fafbec8e32fe2c4254d4e62722b6e744cfa27470ce517d08025b0492e8c032663b094344e SHA512 80f82699c6b64248f0609fb34e54e3838e642040820381cc64feb70b46721b69207686f9cccd55ebfb10dfcdee5fb5c1bf6404d1cfec07eb5a97767635c5dc4e
DIST indexed_gzip-1.7.1.tar.gz 74457 BLAKE2B b22d2120adac59e64f5bcf38c831bb54ce5d6c3dd1e959eece9a454908d9ce2aa5dc10557bd63823616bedfe9d0c039a3f1c0512ef1d22a54437353c57e15158 SHA512 fa27e476f115eca1d1d3892c3480de97cb407bd489737bebc44eb28e92be91e14312cde33a67af145b44c7d93ccc706498c2cbfe6cbff5b9b091dd083cde0f7e
diff --git a/dev-python/indexed_gzip/indexed_gzip-1.7.0.ebuild b/dev-python/indexed_gzip/indexed_gzip-1.7.0.ebuild
deleted file mode 100644
index 859539ace845..000000000000
--- a/dev-python/indexed_gzip/indexed_gzip-1.7.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Fast random access of gzip files in Python"
-HOMEPAGE="
- https://pypi.org/project/indexed-gzip/
- https://github.com/pauldmccarthy/indexed_gzip/
-"
-SRC_URI="
- https://github.com/pauldmccarthy/indexed_gzip/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
-"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- sys-libs/zlib:=
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # strip custom "clean" command that doesn't support "-a"
- # https://bugs.gentoo.org/838955
- # TODO: this can be removed once distutils-r1 stops using clean
- sed -e '/cmdclass/d' -i setup.py || die
- distutils-r1_src_prepare
-}
-
-src_compile() {
- if use test; then
- export INDEXED_GZIP_TESTING=1
- fi
- distutils-r1_src_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}/install$(python_get_sitedir)/indexed_gzip/tests" || die
- epytest
-}