summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-09 20:20:47 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-09 20:48:21 +0300
commit51131963fa29b6551d14b0e5a2e486e610793b51 (patch)
tree381c5ce415755a9a90595fbfa750587376775715 /dev-python/inflect
parentdev-java/javassist: partly revert 8a1f6a090df1f642 (diff)
downloadgentoo-51131963fa29b6551d14b0e5a2e486e610793b51.tar.gz
gentoo-51131963fa29b6551d14b0e5a2e486e610793b51.tar.bz2
gentoo-51131963fa29b6551d14b0e5a2e486e610793b51.zip
dev-python/inflect: add 5.6.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/inflect')
-rw-r--r--dev-python/inflect/Manifest1
-rw-r--r--dev-python/inflect/inflect-5.6.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/inflect/Manifest b/dev-python/inflect/Manifest
index 7c906d253351..633068dc6644 100644
--- a/dev-python/inflect/Manifest
+++ b/dev-python/inflect/Manifest
@@ -1 +1,2 @@
DIST inflect-5.6.0.tar.gz 69251 BLAKE2B 49ebba7149fb550a75818a18a47c6524a046855c330d924bbcad7751b09538902cd1f9075a77922defdda1b8d29dd4966569c7f8c1a2364518cef96799ed21cf SHA512 c7cdd57d84b40c2479637eaf37089b2c5c16d738feb28c71f4fbd3fa4e08f0683c8e1a1e47904fb89afb90404ec8652e48941cbd2f1643dfdfebeaaf307e56ac
+DIST inflect-5.6.1.tar.gz 69306 BLAKE2B c465a962abbdda852fd778d09e3966bdb06dd34f56ef624a3f7d63e277b6e178d891aa23709d6591fe31a07acb3c25a7640aabb790ddf4493df82ab735963f98 SHA512 d908786d82e56871344aee716a2b8dd8da51b0f47af363916b47bceb04468ce6f3c321f5f429e12b10f06c100b0a2ebc249b94110518f33ed0844694cf0f108f
diff --git a/dev-python/inflect/inflect-5.6.1.ebuild b/dev-python/inflect/inflect-5.6.1.ebuild
new file mode 100644
index 000000000000..ea873a0cffa0
--- /dev/null
+++ b/dev-python/inflect/inflect-5.6.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Correctly inflect words and numbers"
+HOMEPAGE="
+ https://pypi.org/project/inflect/
+ https://github.com/jaraco/inflect/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest