summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-23 18:03:05 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-23 18:12:59 +0200
commit3fa6ca4202f57bb0d4798208710cff1d5dd3cc79 (patch)
tree5671896afddcf229743f354322a77fb2a4fcb1a2 /dev-python/ipywidgets
parentdev-python/widgetsnbextension: Bump to 4.0.13 (diff)
downloadgentoo-3fa6ca4202f57bb0d4798208710cff1d5dd3cc79.tar.gz
gentoo-3fa6ca4202f57bb0d4798208710cff1d5dd3cc79.tar.bz2
gentoo-3fa6ca4202f57bb0d4798208710cff1d5dd3cc79.zip
dev-python/ipywidgets: Bump to 8.1.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipywidgets')
-rw-r--r--dev-python/ipywidgets/Manifest1
-rw-r--r--dev-python/ipywidgets/ipywidgets-8.1.5.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/Manifest b/dev-python/ipywidgets/Manifest
index 6566d8777047..ec5fae9994da 100644
--- a/dev-python/ipywidgets/Manifest
+++ b/dev-python/ipywidgets/Manifest
@@ -1 +1,2 @@
DIST ipywidgets-8.1.3.tar.gz 116515 BLAKE2B b7a11e7078ddbd99b8713fc3aa63c78118bf00b64c376412c608a622fda1e7d0430accb0959a56a474d2eeba4b5ce531255b52bba591f2806833644e47f2a7bd SHA512 3722e3716f367c6dce88c6ec401d23240c214793672ae76a12b672f77c7c801775d3253e1202749e54832d9dc13e4bb5984ec57e21607f12c22aced8874538db
+DIST ipywidgets-8.1.5.tar.gz 116723 BLAKE2B fb616c368e75efd6a88dc1c586f16a33a0a725193e0765b0b0ec4a24764b1e8eb33e85b439a33716806e6eda4038674be8059f450695c87a88c5283d425d80b6 SHA512 b4030cc511f759db75417139575f85a797588fe48e17e7ac7debe7bff3f62ebe14dca86a21599be52b7cc6622fe7bb8e8a3dc41d0fffcabe7f77f15735cd5629
diff --git a/dev-python/ipywidgets/ipywidgets-8.1.5.ebuild b/dev-python/ipywidgets/ipywidgets-8.1.5.ebuild
new file mode 100644
index 000000000000..b25007a604e9
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-8.1.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="
+ https://ipywidgets.readthedocs.io/
+ https://github.com/jupyter-widgets/ipywidgets/
+ https://pypi.org/project/ipywidgets/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/comm-0.1.3[${PYTHON_USEDEP}]
+ >=dev-python/ipython_genutils-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-4.0.12[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-widgets-3.0.12[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/ipython-6.1.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # https://github.com/pypy/pypy/issues/4892
+ ipywidgets/widgets/tests/test_interaction.py::test_interact_noinspect
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}