summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-28 02:47:14 +0100
committerSam James <sam@gentoo.org>2023-07-28 02:48:17 +0100
commite126d70a7f7e0d0b18e3fc211881a879b25e676b (patch)
tree52c41a6ac563da4e7ce9e7597c0c875bef92085c /dev-python/irctokens/irctokens-2.0.2.ebuild
parentsys-apps/pv: add 1.7.17 (diff)
downloadgentoo-e126d70a7f7e0d0b18e3fc211881a879b25e676b.tar.gz
gentoo-e126d70a7f7e0d0b18e3fc211881a879b25e676b.tar.bz2
gentoo-e126d70a7f7e0d0b18e3fc211881a879b25e676b.zip
dev-python/irctokens: new package, add 2.0.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/irctokens/irctokens-2.0.2.ebuild')
-rw-r--r--dev-python/irctokens/irctokens-2.0.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/irctokens/irctokens-2.0.2.ebuild b/dev-python/irctokens/irctokens-2.0.2.ebuild
new file mode 100644
index 000000000000..59b18fb4be10
--- /dev/null
+++ b/dev-python/irctokens/irctokens-2.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="RFC1459 and IRCv3 protocol tokeniser library"
+HOMEPAGE="
+ https://github.com/jesopo/irctokens
+ https://pypi.org/project/irctokens/
+"
+# sdist is broken (missing VERSION)
+SRC_URI="
+ https://github.com/jesopo/irctokens/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.2-exclude-tests.patch
+)
+
+distutils_enable_tests unittest