summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-23 15:12:04 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-23 15:12:04 -0800
commit5669fb733acdc367e793ba5802a494b290e3a021 (patch)
tree16b981898e8130897ff633a69fee9a796448f45a /dev-python/jsonpointer
parentdev-python/rfc3339-validator: New package (diff)
downloadgentoo-5669fb733acdc367e793ba5802a494b290e3a021.tar.gz
gentoo-5669fb733acdc367e793ba5802a494b290e3a021.tar.bz2
gentoo-5669fb733acdc367e793ba5802a494b290e3a021.zip
dev-python/jsonpointer-2.0-r1: revbump, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/jsonpointer')
-rw-r--r--dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild b/dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild
new file mode 100644
index 000000000000..4dbb4962f7a2
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-2.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="https://github.com/stefankoegl/python-json-pointer https://pypi.org/project/jsonpointer/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}