summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-09 22:26:39 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-09 22:26:39 +0100
commitbc0fd965ae43afb491b4c68155b64b1d567b040c (patch)
treeffa928af287770132d729934088c3679438bacd7 /dev-python/jsonrpclib
parentxfce-extra/xfce4-weather-plugin: Bump to 0.10.2 (diff)
downloadgentoo-bc0fd965ae43afb491b4c68155b64b1d567b040c.tar.gz
gentoo-bc0fd965ae43afb491b4c68155b64b1d567b040c.tar.bz2
gentoo-bc0fd965ae43afb491b4c68155b64b1d567b040c.zip
dev-python/jsonrpclib: Bump to 0.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonrpclib')
-rw-r--r--dev-python/jsonrpclib/Manifest1
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-0.4.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jsonrpclib/Manifest b/dev-python/jsonrpclib/Manifest
index e20de0908c56..d5bed82ecc09 100644
--- a/dev-python/jsonrpclib/Manifest
+++ b/dev-python/jsonrpclib/Manifest
@@ -1 +1,2 @@
DIST jsonrpclib-0.4.1.tar.gz 58293 BLAKE2B 29beafb412402549d625efb2cbd00d75d70a9582a48eb9223d9b8f8778bf186a80936dfb35ad47186634aab862311e048d556958a4133d0f8461163a51ead4e2 SHA512 9e0c06c016a9e117bb0b8e0fa1dd9e472ef2e280ef5efee51d491f339c8792477430390918fc46a2d8bfbbbe4baa9d4289f67775b879d2a49a35fc7bd1e8ecaa
+DIST jsonrpclib-0.4.2.tar.gz 59590 BLAKE2B 4201d62c9be469d7016943acfc84dca56606f17383ac26e86f574c34927ee6131c5c1a9bc5c3934b8324049ac35b1ff5e4e49ca7ef850251ebdf9a42a53e59a4 SHA512 8d9e5ebe8de960272a1ea0a194544d41851f96c5bc16b9eb6984ac4e48ec1aeaee8e4c3846cfe747a737612934d43a3df72bb1267f0608b1cd2d6faba2acc7b2
diff --git a/dev-python/jsonrpclib/jsonrpclib-0.4.2.ebuild b/dev-python/jsonrpclib/jsonrpclib-0.4.2.ebuild
new file mode 100644
index 000000000000..3caeeb9a0089
--- /dev/null
+++ b/dev-python/jsonrpclib/jsonrpclib-0.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/tcalmant/jsonrpclib.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tcalmant/jsonrpclib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+fi
+
+DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
+HOMEPAGE="https://github.com/tcalmant/jsonrpclib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ esetup.py test
+}