summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-13 07:50:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-13 08:15:27 +0200
commitf84054c525d991ba2a787b237e5e9a19717a93da (patch)
treef0d0ec08bb32d5f3b1f499d5cce5448dfdc40e19 /dev-python/jwcrypto
parentdev-python/deprecated: Enable py3.11 (diff)
downloadgentoo-f84054c525d991ba2a787b237e5e9a19717a93da.tar.gz
gentoo-f84054c525d991ba2a787b237e5e9a19717a93da.tar.bz2
gentoo-f84054c525d991ba2a787b237e5e9a19717a93da.zip
dev-python/jwcrypto: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jwcrypto')
-rw-r--r--dev-python/jwcrypto/Manifest1
-rw-r--r--dev-python/jwcrypto/jwcrypto-1.3.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/jwcrypto/Manifest b/dev-python/jwcrypto/Manifest
index a374acbb4deb..d4550976c267 100644
--- a/dev-python/jwcrypto/Manifest
+++ b/dev-python/jwcrypto/Manifest
@@ -1,3 +1,4 @@
DIST jwcrypto-1.0.0.tar.gz 87000 BLAKE2B 6e85d52c26447b07c3d06387ac9e3b7adf585d5dc320c633e80ca2bc1e327f01ac95cec9a0fe2b92f7f8ed7f5650d5ad1a95de500d328b33763d604aaba1bd62 SHA512 12d270219d289041098f875f5b2b0773ffbf9044996a6189b827cafbf3e5dccfc103915275b1a11dce2d50e3510510eea476b024d19cf97fd7c66c25de5b3dbf
DIST jwcrypto-1.1.0.gh.tar.gz 87344 BLAKE2B 4bc72c01e6d49d68ff8e3c89a09758a5e8a634c308926ed2b750fdc373006b30710a841df4e26e1ce3287be6e4b509674887a0b01cc3b225bc87d97588f5b7a6 SHA512 c7530f68d74247f23ad2d76def257f4f0091203a22d39f248f4a15363b17bdf79699b96775cfb7f909b5b0a99ed1dd73ff5ae30ca8bc41662f1be38933c9f3c1
DIST jwcrypto-1.2.0.gh.tar.gz 88369 BLAKE2B c2f03cef2130884e8a27faa5a7e204ee448ef0a2b56da414f10df34821a67898a0ed2768201d00e2dc7d14b5a3cad3e73c0bd5707910dd2cb1082d1a20a14c04 SHA512 df9073b0561b43cd92f7f1861f9b517bc736d0846f8ef1c7496a48aa5dec49755e5915285ae659c5e2bb18cd51912cd782d799c41c5c6399330f688348096fa5
+DIST jwcrypto-1.3.0.gh.tar.gz 91206 BLAKE2B bbc11ae9fe5a27233ad3e27e0ef38fff4bacd4d429fbf7b379b0ee61f4551cc3f8810181ef6e61c196951b971e2e49c5faf34e481b62f2caebd534bcbf26f981 SHA512 6071df4bbb735b7096fab35855534cbcf6bb2244b3e789cac81cc49d1d2f3a79112227a909074e2ee30e9a2fdf13d711f15222a2aeaedf8b7a098d8f569bcc40
diff --git a/dev-python/jwcrypto/jwcrypto-1.3.0.ebuild b/dev-python/jwcrypto/jwcrypto-1.3.0.ebuild
new file mode 100644
index 000000000000..cc2a94b3af64
--- /dev/null
+++ b/dev-python/jwcrypto/jwcrypto-1.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements JWK,JWS,JWE specifications using python-cryptography"
+HOMEPAGE="
+ https://github.com/latchset/jwcrypto/
+ https://pypi.org/project/jwcrypto/
+"
+SRC_URI="
+ https://github.com/latchset/jwcrypto/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-2.3[${PYTHON_USEDEP}]
+ dev-python/deprecated[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install doc in non-standard paths
+ sed -i "/data_files/d" setup.py || die
+ distutils-r1_python_prepare_all
+}