summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-06-06 08:19:18 +0300
committerMichał Górny <mgorny@gentoo.org>2021-08-01 23:23:47 +0200
commit40443c9cac3990e938cecbe37492ba580fb0763b (patch)
tree121715ef55252a63f160dbffc3c911816279337e /dev-python/kafka-python
parentdev-python/xxhash: keyword 2.0.2 for ~x86 (diff)
downloadgentoo-40443c9cac3990e938cecbe37492ba580fb0763b.tar.gz
gentoo-40443c9cac3990e938cecbe37492ba580fb0763b.tar.bz2
gentoo-40443c9cac3990e938cecbe37492ba580fb0763b.zip
dev-python/kafka-python: add 2.0.2, bump py3.10, fix test
- bump to python 3.10 - use optfeatures for all extra dependencies - remove dependency on dev-python/unittest2 Closes: https://bugs.gentoo.org/723602 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/kafka-python')
-rw-r--r--dev-python/kafka-python/Manifest1
-rw-r--r--dev-python/kafka-python/kafka-python-2.0.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/kafka-python/Manifest b/dev-python/kafka-python/Manifest
index 1db6ff139ac4..85b0e67e3638 100644
--- a/dev-python/kafka-python/Manifest
+++ b/dev-python/kafka-python/Manifest
@@ -1 +1,2 @@
DIST kafka-python-1.4.7.tar.gz 352844 BLAKE2B 812c185bf19f3398c358722a44feb572693556ec671d07f2d74d63e45473f5b6d35390cc0fa2c95b8c42a15b635237ffa3c3829adde1f60a7611ce4fdf06f587 SHA512 5bbf9f998fba12e8e7c67a48e82b04e745f1ac528684e91b7454e825656e4a68b8c369984308cff575241b7f808f52f16ab02b7effd6d6b4319215f44ae4748e
+DIST kafka-python-2.0.2.tar.gz 327238 BLAKE2B 9d8bdee1cedcc3c7c0bee9d900bb815552b29f50ec45b7db9d1052a26eb772c84d92648ccc0d498189fc44314f5c8c30529fa61cb983481f2e2480e009630f91 SHA512 e193a8fe5852d2134e854749115feba46a0b8ff748336989a27bf56acba1124dbb8a5d841670a67ee26eef030a686d931d03d329f978b2eef7904183e83d2594
diff --git a/dev-python/kafka-python/kafka-python-2.0.2.ebuild b/dev-python/kafka-python/kafka-python-2.0.2.ebuild
new file mode 100644
index 000000000000..fd96a67c40f0
--- /dev/null
+++ b/dev-python/kafka-python/kafka-python-2.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Kafka protocol support in Python"
+HOMEPAGE="https://github.com/dpkp/kafka-python/ https://pypi.org/project/kafka-python/"
+SRC_URI="https://github.com/dpkp/kafka-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/xxhash[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/lz4[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/snappy[${PYTHON_USEDEP}]
+ dev-python/zstandard[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # Needs the unpackaged crc32c module
+ test/record/test_util.py::test_crc32c[None]
+ # Needs kafka server running
+ test/test_consumer_integration.py::test_kafka_consumer_offsets_for_time_old
+ )
+ epytest ${deselect[@]/#/--deselect }
+}
+
+pkg_postinst() {
+ optfeature "LZ4 compression/decompression support" dev-python/lz4
+ optfeature "Snappy compression support" dev-python/snappy
+ optfeature "ZSTD compression/decompression support" dev-python/zstandard
+}