summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-02 21:55:39 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-02 23:59:11 +0100
commit71d39fc92b5c7ff60c2080a66a595bc5c39e50ee (patch)
tree544fd01797419b3447c0969c6b9a8db64510910a /dev-python/kombu
parentdev-python/regex: Bump to 2021.11.2 (diff)
downloadgentoo-71d39fc92b5c7ff60c2080a66a595bc5c39e50ee.tar.gz
gentoo-71d39fc92b5c7ff60c2080a66a595bc5c39e50ee.tar.bz2
gentoo-71d39fc92b5c7ff60c2080a66a595bc5c39e50ee.zip
dev-python/kombu: Bump to 5.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/kombu')
-rw-r--r--dev-python/kombu/Manifest1
-rw-r--r--dev-python/kombu/kombu-5.2.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/kombu/Manifest b/dev-python/kombu/Manifest
index a21f167444e5..c520b20769f9 100644
--- a/dev-python/kombu/Manifest
+++ b/dev-python/kombu/Manifest
@@ -1 +1,2 @@
DIST kombu-5.1.0.tar.gz 416353 BLAKE2B 2c26aac0a8eda62475e2a9a859b2548046dfce0699a8dafce3cc6471ee3b82f82882a53903a86f69cf16f948e4d0e66f379479f7f1f46aca2bcbdd031ba87811 SHA512 62ef16e8e3fb592882b8060f29b95e7224ba635132ed688eece0c2d254e7f7fb525c778cac23f15495464c6dbcf84d7a1372fde6f55fcfe66677cf43d3e9d4de
+DIST kombu-5.2.0.tar.gz 419952 BLAKE2B 99065bc89152ce6b8646d74fd77eb162150313b30d911a6d3d58cefc279bf7539742cd259fad456925796e718f732d3a0243a3e3cca99d2cae5e5de575489359 SHA512 c5336e239c69cb584cca9dfca137f0bc27ee24d4a2f260d78d70e18925528cd97763a805eefb7270617aad499f9f9a66ed0eaa9acf418e1ae950727c01a84b6e
diff --git a/dev-python/kombu/kombu-5.2.0.ebuild b/dev-python/kombu/kombu-5.2.0.ebuild
new file mode 100644
index 000000000000..22dee35e6bf5
--- /dev/null
+++ b/dev-python/kombu/kombu-5.2.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="AMQP Messaging Framework for Python"
+HOMEPAGE="https://pypi.org/project/kombu/ https://github.com/celery/kombu"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/py-amqp-5.0.6[${PYTHON_USEDEP}]
+ <dev-python/py-amqp-6.0.0[${PYTHON_USEDEP}]
+ dev-python/vine[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.4.4[${PYTHON_USEDEP}]
+ >=dev-python/case-1.5.2[${PYTHON_USEDEP}]
+ dev-python/kazoo[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ >=dev-python/pymongo-3.3.0[${PYTHON_USEDEP}]
+ dev-python/Pyro4[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-3.3.11[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/zstandard[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_celery
+
+EPYTEST_IGNORE=(
+ # Unpackaged azure-servicebus
+ t/unit/transport/test_azureservicebus.py
+ # Unpackaged librabbitmq
+ t/unit/transport/test_librabbitmq.py
+ # Unpackaged python-consul
+ t/unit/transport/test_consul.py
+ # AttributeError: test_Etcd instance has no attribute 'patch'
+ t/unit/transport/test_etcd.py
+)
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Amazon SQS backend" "dev-python/boto3 dev-python/pycurl"
+ optfeature "Etcd backend" dev-python/python-etcd
+ optfeature "MongoDB backend" dev-python/pymongo
+ optfeature "Pyro 4 backend" dev-python/Pyro4
+ optfeature "Redis backend" dev-python/redis-py
+ optfeature "sqlalchemy backend" dev-python/sqlalchemy
+ optfeature "yaml backend" dev-python/pyyaml
+ optfeature "Zookeeper backend" dev-python/kazoo
+ optfeature "MessagePack (de)serializer for Python" dev-python/msgpack
+ optfeature "brotli compression" "app-arch/brotli[python]"
+ optfeature "zstd compression" dev-python/zstandard
+}