summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-06-09 13:09:10 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2017-06-09 13:11:05 +0200
commitdd78e88cf1ab93644cb416ac5e599470e5144ccc (patch)
tree3f2c7933509dee2d57e47c0f38586553036eea50 /dev-python/libpillowfight/libpillowfight-0.2.2.ebuild
parentprofiles: Adjust package.use.mask for sys-process/fcron on x86-fbsd (diff)
downloadgentoo-dd78e88cf1ab93644cb416ac5e599470e5144ccc.tar.gz
gentoo-dd78e88cf1ab93644cb416ac5e599470e5144ccc.tar.bz2
gentoo-dd78e88cf1ab93644cb416ac5e599470e5144ccc.zip
dev-python/libpillowfight: 0.2.2 bump
Update homepage and python compatibility Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/libpillowfight/libpillowfight-0.2.2.ebuild')
-rw-r--r--dev-python/libpillowfight/libpillowfight-0.2.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/libpillowfight/libpillowfight-0.2.2.ebuild b/dev-python/libpillowfight/libpillowfight-0.2.2.ebuild
new file mode 100644
index 000000000000..ccb2ccc8455d
--- /dev/null
+++ b/dev-python/libpillowfight/libpillowfight-0.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Small library containing various image processing algorithms"
+HOMEPAGE="https://github.com/openpaperwork/libpillowfight"
+SRC_URI="https://github.com/openpaperwork/libpillowfight/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -e "/'nose>=1.0'/d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}