summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-22 20:30:23 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-22 22:00:48 +0200
commit0f5634c8fd8d3d35a3ffca5654cd2ee7a9934c2f (patch)
treef66ada976bed538f3908d094d379177ff90e3ffa /dev-python/line-profiler
parentmedia-video/qmplay2: drop 23.06.17-r1 (diff)
downloadgentoo-0f5634c8fd8d3d35a3ffca5654cd2ee7a9934c2f.tar.gz
gentoo-0f5634c8fd8d3d35a3ffca5654cd2ee7a9934c2f.tar.bz2
gentoo-0f5634c8fd8d3d35a3ffca5654cd2ee7a9934c2f.zip
dev-python/line-profiler: Bump to 4.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/line-profiler')
-rw-r--r--dev-python/line-profiler/Manifest1
-rw-r--r--dev-python/line-profiler/line-profiler-4.1.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/line-profiler/Manifest b/dev-python/line-profiler/Manifest
index 58cb858bdbd3..2de3bc4cfc2c 100644
--- a/dev-python/line-profiler/Manifest
+++ b/dev-python/line-profiler/Manifest
@@ -1 +1,2 @@
DIST line_profiler-4.1.0.gh.tar.gz 99250 BLAKE2B aa875dfb8cdbaaa701a03d10fd904504825d58e551dddabddbe0abca777a584bae5c37f4b3ab80d10dc869138106d70c3ff243a7d28e570983427520dd4ee569 SHA512 08e0395b80f8c111725227abea7e8b2d6864da840a0a6f4de5eb71a2df2ae78871c930897b49d75a184973c1ce21d61106817bd0b8d4556462f0505bbbc21fe1
+DIST line_profiler-4.1.1.gh.tar.gz 99299 BLAKE2B fa5e1588167d4e1b451ebeef6bd625c25053e0370268fb435ae6cd72e5e56c0a6252cf3970d8e2bd7952bf61d16662128f68d5106aee8190bc9fe65d3180cf2d SHA512 4170d1b89b3b8e4bbeaf9ce145f67214ef133ea87d6c02d59f5da0ddab30fc14a89d11bbd749e9707c4a0654db23b22eef7f73749ee3023544835f562da62762
diff --git a/dev-python/line-profiler/line-profiler-4.1.1.ebuild b/dev-python/line-profiler/line-profiler-4.1.1.ebuild
new file mode 100644
index 000000000000..5ffe92f3463f
--- /dev/null
+++ b/dev-python/line-profiler/line-profiler-4.1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=line_profiler-${PV}
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="
+ https://github.com/pyutils/line_profiler/
+ https://pypi.org/project/line-profiler/
+"
+SRC_URI="
+ https://github.com/pyutils/line_profiler/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+# <cython-3: https://bugs.gentoo.org/911735
+BDEPEND="
+ <dev-python/cython-3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ubelt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export LINE_PROFILER_BUILD_METHOD=cython
+
+python_test() {
+ cd tests || die
+ epytest
+}