summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/louie
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/louie')
-rw-r--r--dev-python/louie/Manifest1
-rw-r--r--dev-python/louie/louie-1.1-r1.ebuild35
-rw-r--r--dev-python/louie/louie-1.1.ebuild33
-rw-r--r--dev-python/louie/metadata.xml8
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/louie/Manifest b/dev-python/louie/Manifest
new file mode 100644
index 000000000000..881d76787cd2
--- /dev/null
+++ b/dev-python/louie/Manifest
@@ -0,0 +1 @@
+DIST Louie-1.1.tar.gz 22306 SHA256 75f33f2978e9a7ba1f541c594d8e93d0c4a965a706db688fd11a77f4049e5a5b SHA512 4f5426da4bfbf7a5928007a82e155414e7db9d466397eb9cba6a5fcfddccf4bd162071e5d551fb6ffd41f0b780097a89eea6c268e2d4fb32264683f796d85ec0 WHIRLPOOL e3b6ac3769ec7097914e4b73b9064fa2be6d4be358a661087c0d002a472e36435e0ec1665958e56857f581ce8b88f0827c84d68c966d18184d403109bc6e2746
diff --git a/dev-python/louie/louie-1.1-r1.ebuild b/dev-python/louie/louie-1.1-r1.ebuild
new file mode 100644
index 000000000000..fe1b263c3e77
--- /dev/null
+++ b/dev-python/louie/louie-1.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Louie"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Signal dispatching mechanism for Python"
+HOMEPAGE="http://pypi.python.org/pypi/Louie"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed -e "/'nose >= 0.8.3'/d" -i setup.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/louie/louie-1.1.ebuild b/dev-python/louie/louie-1.1.ebuild
new file mode 100644
index 000000000000..71b311c42655
--- /dev/null
+++ b/dev-python/louie/louie-1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="Louie"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Signal dispatching mechanism for Python"
+HOMEPAGE="http://pypi.python.org/pypi/Louie"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils_src_prepare
+ sed -e "/'nose >= 0.8.3'/d" -i setup.py || die "sed failed"
+}
diff --git a/dev-python/louie/metadata.xml b/dev-python/louie/metadata.xml
new file mode 100644
index 000000000000..4053af5244ec
--- /dev/null
+++ b/dev-python/louie/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Louie</remote-id>
+ </upstream>
+</pkgmetadata>