summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-01-26 15:25:51 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-01-26 15:25:51 -0600
commit3d21d0bb7eadb28bf7c36bededd03f2ed8adf475 (patch)
tree8f9e00d2e5974d0de4f3a429cacf62f03d4a8cf3 /dev-python/markdown
parentdev-python/hacking: 2.0.0 stable amd64 / x86 fast (diff)
downloadgentoo-3d21d0bb7eadb28bf7c36bededd03f2ed8adf475.tar.gz
gentoo-3d21d0bb7eadb28bf7c36bededd03f2ed8adf475.tar.bz2
gentoo-3d21d0bb7eadb28bf7c36bededd03f2ed8adf475.zip
dev-python/markdown: 2.6.11 bump for netbox
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/markdown')
-rw-r--r--dev-python/markdown/Manifest1
-rw-r--r--dev-python/markdown/markdown-2.6.11.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/markdown/Manifest b/dev-python/markdown/Manifest
index a9ed987ceca7..91cfebf8aad1 100644
--- a/dev-python/markdown/Manifest
+++ b/dev-python/markdown/Manifest
@@ -1,3 +1,4 @@
+DIST Markdown-2.6.11.tar.gz 274132 BLAKE2B 0d14d308c97d925db83d71f3b9be5622e77ee4a159fced15c811390b39950e81bff9ffc567f32e878cbc44014640ab0a2f596258cfd0dce6b66029105cec7370 SHA512 4e7dd3e04f181fa2751a359aede301fb29a23b9af74867ff9d1d0fdd051dcd16d04a5891e37aff0b309649c5fd13363802ec7e10fc33896e9453991efcab4a66
DIST Markdown-2.6.8.tar.gz 307330 BLAKE2B 6867f15425bd84bc030ab52000dc2f83bff0c9885854cec4a2a785f80b18129160bc57da30226fe17f42043b4938482e2e4eff9cdb3d4370b0146cc09f1ff576 SHA512 85c1a16ebb50af79f378eb2fa936342df6174a4f597a74fee6d0495ef2bc4c7c8337463799e427cb6788b3429e400309958b5c4784f536593047ab2e47ac7c23
DIST Markdown-3.0.1.tar.gz 284084 BLAKE2B 6a9250295057ed32b389e1aeecf9aa3acac37ef48e6ca93a4821eb56a2323d65c1aed99799bf05811f27f45ba61f7bb704f69c6d2be706d8d2764c026e937905 SHA512 c648c1b8ecb3c907ff2bd636ec6c08b4b629967fb916913f77db641f6d61b83d16929af2f15f5695c8cdb9614031606110e02a7e0bbb3aab0be38a8e285f12f1
DIST Markdown-3.1.1.tar.gz 294136 BLAKE2B 9fd024f64f7aaa774a49f60e312e47bbc2ff0f368f083e4dfd0c38d1f12839dfcf3455f1d0c8cb0b9c851fe0d3a779c70784859f1682703bd6022d57b6548235 SHA512 78f089f2eef5c73d683ac96fd20c87145e243d12b0f230b9b0228b995035fbb084dde40be788679c63637f05956487ad520cc9dd61d133926bf13521aa600090
diff --git a/dev-python/markdown/markdown-2.6.11.ebuild b/dev-python/markdown/markdown-2.6.11.ebuild
new file mode 100644
index 000000000000..371d2feea395
--- /dev/null
+++ b/dev-python/markdown/markdown-2.6.11.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the markdown markup language"
+HOMEPAGE="
+ https://python-markdown.github.io/
+ https://pypi.org/project/Markdown/
+ https://github.com/Python-Markdown/markdown"
+SRC_URI="mirror://pypi/M/${PN^}/${P^}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc
+~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test pygments"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytidylib[${PYTHON_USEDEP}]
+ )"
+# source cites pytidylib however from testruns it appears optional
+RDEPEND="pygments? ( dev-python/pygments[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${P^}"
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_docs
+ HTML_DOCS=( "${BUILD_DIR}"/docs/. )
+
+ # remove .txt files
+ find "${BUILD_DIR}"/docs -name '*.txt' -delete || die
+ fi
+}
+
+python_test() {
+ cp -r -l run-tests.py tests "${BUILD_DIR}"/ || die
+ cd "${BUILD_DIR}" || die
+ "${EPYTHON}" run-tests.py || die "Tests fail with ${EPYTHON}"
+}