summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-06 17:37:32 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-06 18:17:06 +0200
commit2ae8eca23c89df23e7a2dfe72ee08420e6c02c7d (patch)
tree326a915906f40b1e3e26eb4effea29cf67c6b9f5 /dev-python/marshmallow
parentdev-python/webcolors: Bump to 24.6.0 (diff)
downloadgentoo-2ae8eca23c89df23e7a2dfe72ee08420e6c02c7d.tar.gz
gentoo-2ae8eca23c89df23e7a2dfe72ee08420e6c02c7d.tar.bz2
gentoo-2ae8eca23c89df23e7a2dfe72ee08420e6c02c7d.zip
dev-python/marshmallow: Bump to 3.21.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.21.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index 89c97fe684fd..9e56b67589b9 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1 +1,2 @@
DIST marshmallow-3.21.2.gh.tar.gz 183818 BLAKE2B 01e14514d836c36c9f24a6e0a527271bd17ea5ce1ce35cabb6200a886c85ef970e7d54191307d1580568f05b501ec6028c7f126475ac64c160fec75c247a4c20 SHA512 b151f7e712dc5dd5d7f592942a6a4b09d462b684f542406c8bc57237e4b2402eb287d02e4ca2ef65e10dccb1e200b9ff8ae24f69160af1c6aa02fc5dfdc9eeba
+DIST marshmallow-3.21.3.gh.tar.gz 183813 BLAKE2B c5b0165be783e87149c1f1b7f0e370c0c0b33cd5e34b0a91b1510b81e840ca1f87c34b13f00e0c22b5a34d8fec62bba4a66f889a450a4f03fda7a85a63bf71bf SHA512 522d015d4207b1258ef92901f106f94bd412e011c26ad074ca9ee3156e51a1d873063f0ebd24b613cd95f34397f29e79358bb420ee0eef51095e6e8858d61fca
diff --git a/dev-python/marshmallow/marshmallow-3.21.3.ebuild b/dev-python/marshmallow/marshmallow-3.21.3.ebuild
new file mode 100644
index 000000000000..f7d269422f0f
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.21.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="
+ https://github.com/marshmallow-code/marshmallow/
+ https://pypi.org/project/marshmallow/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/marshmallow/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-17.0[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest