summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-10 05:38:16 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-10 05:38:16 +0100
commit82117d84b7d91a3099370589469711fdabd37ceb (patch)
tree35e58b924df577fa9b8473c27836ff788e59f265 /dev-python/marshmallow
parentdev-python/environs: Bump to 10.2.0 (diff)
downloadgentoo-82117d84b7d91a3099370589469711fdabd37ceb.tar.gz
gentoo-82117d84b7d91a3099370589469711fdabd37ceb.tar.bz2
gentoo-82117d84b7d91a3099370589469711fdabd37ceb.zip
dev-python/marshmallow: Bump to 3.20.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.20.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index 61307dde8e2f..fdf77bbaf704 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1 +1,2 @@
DIST marshmallow-3.20.1.gh.tar.gz 183718 BLAKE2B f1e8011be42f6a94d8d2bfde70d2761b3a3efdbce1ca61445d11b8b1e2e2f79953abd4fcefcd9bfcb3370458c9bb0084a2697b8537af8f58d161bb0d19559170 SHA512 8d2eeadad42811b2311f70c8eb0101d88a53fa8d4216a2ab44e67a508f5514c65c35932e1d3d2000b5cbd77ee4aae2be0e29a82576c3917f5db640f4af078b53
+DIST marshmallow-3.20.2.gh.tar.gz 183876 BLAKE2B 84cf8ca23069ad1d2353ffa9299556298457485fa459746b948835f04f92ef3949d5429e8285e084be7398fb294b3d74eba1b38ef21b469daed401f1e6affcdb SHA512 8305693405a976c53333b0c6ef074a12af4736f9620ca37c7c2ec6318fac2b19086426344ce8c2f515e95becdba8b2bb1c20aca5a9dffb4145cb27fee00dc080
diff --git a/dev-python/marshmallow/marshmallow-3.20.2.ebuild b/dev-python/marshmallow/marshmallow-3.20.2.ebuild
new file mode 100644
index 000000000000..95b74278c863
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.20.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="
+ https://github.com/marshmallow-code/marshmallow/
+ https://pypi.org/project/marshmallow/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/marshmallow/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-0.17[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest