summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-03 13:59:53 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-03 14:01:45 +0200
commite8d080443a4a1c791446edbf766b408d32df5e7c (patch)
treed0d332433d8de0dba4afbc208956043b17d5858f /dev-python/matplotlib
parentdev-libs/libpqxx: Cleanup (diff)
downloadgentoo-e8d080443a4a1c791446edbf766b408d32df5e7c.tar.gz
gentoo-e8d080443a4a1c791446edbf766b408d32df5e7c.tar.bz2
gentoo-e8d080443a4a1c791446edbf766b408d32df5e7c.zip
dev-python/matplotlib: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/matplotlib-3.5.2-r3.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/matplotlib/matplotlib-3.5.2-r3.ebuild b/dev-python/matplotlib/matplotlib-3.5.2-r3.ebuild
index e154653a5a4d..d62922e0914d 100644
--- a/dev-python/matplotlib/matplotlib-3.5.2-r3.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.5.2-r3.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE='tk?,threads(+)'
inherit distutils-r1 flag-o-matic multiprocessing prefix toolchain-funcs \
@@ -80,7 +80,9 @@ RDEPEND="
>=www-servers/tornado-6.0.4[${PYTHON_USEDEP}]
)
wxwidgets? (
- dev-python/wxpython:*[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/wxpython:*[${PYTHON_USEDEP}]
+ ' python3_{8..10})
)
"
@@ -247,6 +249,11 @@ python_test() {
"tests/test_rcparams.py::test_validator_invalid[validate_strlist-arg7-MatplotlibDeprecationWarning]"
tests/test_testing.py::test_warn_to_fail
)
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # https://github.com/matplotlib/matplotlib/issues/23384
+ "tests/test_backends_interactive.py::test_figure_leak_20490[time_mem1-{'MPLBACKEND': 'qtagg', 'QT_API': 'PyQt5'}]"
+ "tests/test_backends_interactive.py::test_figure_leak_20490[time_mem1-{'MPLBACKEND': 'qtcairo', 'QT_API': 'PyQt5'}]"
+ )
# we need to rebuild mpl against bundled freetype, otherwise
# over 1000 tests will fail because of mismatched font rendering