summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-20 13:51:24 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-10-20 13:51:35 +0200
commitd202906a3d5c708d2d12a6daa0b14de99cb3c4b8 (patch)
tree724d2a38da9680402b241d1bf6a723577026f420 /dev-python/mkdocs
parentdev-python/ghp-import: add version 2.0.2 (diff)
downloadgentoo-d202906a3d5c708d2d12a6daa0b14de99cb3c4b8.tar.gz
gentoo-d202906a3d5c708d2d12a6daa0b14de99cb3c4b8.tar.bz2
gentoo-d202906a3d5c708d2d12a6daa0b14de99cb3c4b8.zip
dev-python/mkdocs: add version 1.2.3
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/mkdocs')
-rw-r--r--dev-python/mkdocs/Manifest1
-rw-r--r--dev-python/mkdocs/mkdocs-1.2.3.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/mkdocs/Manifest b/dev-python/mkdocs/Manifest
index 387f97be7b34..905586879663 100644
--- a/dev-python/mkdocs/Manifest
+++ b/dev-python/mkdocs/Manifest
@@ -1 +1,2 @@
DIST mkdocs-1.2.2.tar.gz 6919165 BLAKE2B eba8d585c3653640bd3babbba3a1fab6aa9dc3ee365536ee7b0956e38250611bab3180c6a7f08eefb1e1a3637d07a0f366179570a9bb69df4f02a605610a770f SHA512 6cb111fcb3167a39e1d282d24b5e67d806c3e7506f55ef11a227b37ceeaea950142db2bc1db3709caaa2813c62ef8c4ef74aeb26e62f4f10aeee528e0532eccd
+DIST mkdocs-1.2.3.tar.gz 6919177 BLAKE2B 43ff118149a497dd366f7132487564be51ffeaff644a519c7bf9e52a3e3239e9696c21616e5d7494f7c4af8ee60ec77f27fd15e80f5c5c6c1b2db4cf1f672e44 SHA512 03385bc940df8a6b3668300f3752afe973b95f149bee58217ace82063aacb661dbd000a2a7a383c4804434473c3945cec3cb41d6608388350da3098c32709541
diff --git a/dev-python/mkdocs/mkdocs-1.2.3.ebuild b/dev-python/mkdocs/mkdocs-1.2.3.ebuild
new file mode 100644
index 000000000000..3087ec3003c1
--- /dev/null
+++ b/dev-python/mkdocs/mkdocs-1.2.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Project documentation with Markdown"
+HOMEPAGE="https://www.mkdocs.org https://github.com/mkdocs/mkdocs"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+IUSE="doc"
+
+BDEPEND="
+ doc? (
+ $(python_gen_any_dep '
+ dev-python/mdx_gh_links[${PYTHON_USEDEP}]
+ dev-python/mkdocs-redirects[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+RDEPEND="
+ >=dev-python/Babel-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/click-3.3[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.2.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-2.0[${PYTHON_USEDEP}]
+ >=dev-python/ghp-import-1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml_env_tag-0.1[${PYTHON_USEDEP}]
+ >=dev-python/importlib_metadata-3.10[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.5[${PYTHON_USEDEP}]
+ >=dev-python/mergedeep-1.3.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests --install nose
+
+python_prepare_all() {
+ # Tests fails if additional themes are installed
+ sed -i -e 's:test_get_themes:_&:' \
+ mkdocs/tests/utils/utils_tests.py || die
+
+ # Skip this network test, "does not appear to be an IPv4 or IPv6 address"
+ sed -i -e 's/test_IP_normalization/_&/' \
+ mkdocs/tests/config/config_options_tests.py || die
+
+ # livereload has been dropped in this release, this test is a remnant
+ rm mkdocs/tests/livereload_tests.py || die
+
+ # fix apparent typo in test (importing wrong thing)
+ sed -i -e 's/from localization import/from mkdocs.localization import/g' \
+ mkdocs/tests/theme_tests.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ default
+ if use doc; then
+ # cannot just do mkdocs build, because that fails if
+ # the package isn't already installed
+ python -m mkdocs build || die "Failed to make docs"
+ # Colliding files found by ecompress:
+ rm site/sitemap.xml.gz || die
+ HTML_DOCS=( "site/." )
+ fi
+}