summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:43:12 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:53:25 +0200
commit0f919a927505e75ba9f208890e1b0bd423ea21fa (patch)
tree3b5417800e1622e81fd6ef27fa686666b48f2180 /dev-python/moto
parentdev-python/more-itertools: Remove redundant versions (diff)
downloadgentoo-0f919a927505e75ba9f208890e1b0bd423ea21fa.tar.gz
gentoo-0f919a927505e75ba9f208890e1b0bd423ea21fa.tar.bz2
gentoo-0f919a927505e75ba9f208890e1b0bd423ea21fa.zip
dev-python/moto: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-1.3.8-r2.ebuild76
2 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index f46269349819..c9c1477018d8 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -1,2 +1 @@
DIST moto-1.3.14.tar.gz 1829165 BLAKE2B 2ec30c4cc571492a9d2c08f66a39ad04cfc0baa7864db8a5be4ea9af24ecb59bad3e85c44fa8a7babc16bf66188cb6bef89484f1f302a11e6eec1f8dbf516492 SHA512 1fe7e9d49dadada82f24d6bef1c21419c414e027c21ed1099bd1eab7c269ac5638ed44a29d1557b37562a44b22a7c7251fc1ca8ba88cde6b82d39dbc620aa6a6
-DIST moto-1.3.8.tar.gz 1571716 BLAKE2B 8e79808d8488bcf8c15e8b5a55e93392ceb5f642f1f52c0af441cecb7adfe23a718f6d283e473e5dab82ddd21bcbed36ecb52b444cbd933405d13c8818e4f74d SHA512 901556249a2a28885b7f77e9f2c209b06391efcea66b78ce3c16edec14bcd03b251c37ef5d800d8f7a35180d59ce7568a68bcebf18e25b092eb5de801db6c587
diff --git a/dev-python/moto/moto-1.3.8-r2.ebuild b/dev-python/moto/moto-1.3.8-r2.ebuild
deleted file mode 100644
index f930603b5ece..000000000000
--- a/dev-python/moto/moto-1.3.8-r2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Mock library for boto"
-HOMEPAGE="https://github.com/spulec/moto"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
- dev-python/backports-tempfile[${PYTHON_USEDEP}]
- dev-python/cfn-python-lint[${PYTHON_USEDEP}]
- >=dev-python/cryptography-2.3.0[${PYTHON_USEDEP}]
- dev-python/cookies[${PYTHON_USEDEP}]
- dev-python/dicttoxml[${PYTHON_USEDEP}]
- >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
- >=dev-python/idna-2.5[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
- >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
- >=dev-python/boto-2.36.0[${PYTHON_USEDEP}]
- >=dev-python/boto3-1.9.86[${PYTHON_USEDEP}]
- >=dev-python/botocore-1.12.86[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pretty-yaml[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/python-jose[${PYTHON_USEDEP}]
- >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.5[${PYTHON_USEDEP}]
- dev-python/xmltodict[${PYTHON_USEDEP}]
- >=dev-python/six-1.9[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
-"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- sed -e 's|==|>=|' \
- -i setup.py moto.egg-info/requires.txt || die
-
- # Disable tests that fail with network-sandbox.
- sed -e 's|^\(def \)\(test_context_manager()\)|\1_\2|' \
- -e 's|^\(def \)\(test_decorator_start_and_stop()\)|\1_\2|' \
- -i tests/test_core/test_decorator_calls.py || die
-
- # Disable tests that fail with userpriv.
- sed -e 's|^\(def \)\(test_invoke_function_from_sns()\)|\1_\2|' \
- -e 's|^\(def \)\(test_invoke_requestresponse_function()\)|\1_\2|' \
- -i tests/test_awslambda/test_lambda.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- PYTHONPATH=${BUILDDIR}/lib \
- nosetests -sv ./tests || die
-}