summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-23 07:01:49 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-23 07:07:15 +0200
commit46008480131454a62a58afd45f45efd41799c9c3 (patch)
tree7458c4c385426f20d610a4c631444eaa1c46ced2 /dev-python/nbclient
parentdev-python/requests: Bump to 2.31.0 (diff)
downloadgentoo-46008480131454a62a58afd45f45efd41799c9c3.tar.gz
gentoo-46008480131454a62a58afd45f45efd41799c9c3.tar.bz2
gentoo-46008480131454a62a58afd45f45efd41799c9c3.zip
dev-python/nbclient: Bump to 0.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbclient')
-rw-r--r--dev-python/nbclient/Manifest1
-rw-r--r--dev-python/nbclient/nbclient-0.8.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/nbclient/Manifest b/dev-python/nbclient/Manifest
index 61aff6c14783..4f6cd63bfde4 100644
--- a/dev-python/nbclient/Manifest
+++ b/dev-python/nbclient/Manifest
@@ -1 +1,2 @@
DIST nbclient-0.7.4.gh.tar.gz 79167 BLAKE2B 90b61c55cf25aaa2fed8fd914d799619fefb1353826f7a41320efb732ccf7a44efce944c03d472f9f441a1693bfcdce76e23d0746d62c020e996dc55de7be2b6 SHA512 24cdb1d8b9ffc4899f15490f15d5a41a3e62c52c2b57d8ee768dc93fda08bb6f1a432306a551ece3d031061f790e032c765b0d96225700b2820ca59bc71e9aeb
+DIST nbclient-0.8.0.gh.tar.gz 79287 BLAKE2B 5147195fa75ae5da620eb44b5b3d360f69275f1590d098757c6f460769bdb62d3eca576a344861e382bf430f97159adbfff46f557c3509d5fe06d269a0302cdc SHA512 f77ecba2f03a8886e8a2335e1d345fcc1d3a1726b458d151a8c78b85c621017cd96f1ef30e4532bf61b89c92aea128a364f5e9677858951f5d070c6206a01816
diff --git a/dev-python/nbclient/nbclient-0.8.0.ebuild b/dev-python/nbclient/nbclient-0.8.0.ebuild
new file mode 100644
index 000000000000..a538de91f03f
--- /dev/null
+++ b/dev-python/nbclient/nbclient-0.8.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client library for executing Jupyter notebooks"
+HOMEPAGE="
+ https://nbclient.readthedocs.io/en/latest/
+ https://github.com/jupyter/nbclient/
+ https://pypi.org/project/nbclient/
+"
+SRC_URI="
+ https://github.com/jupyter/nbclient/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter-client-6.1.12[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-6.19.3[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ nbclient/tests/test_client.py::test_many_parallel_notebooks
+ 'nbclient/tests/test_client.py::test_run_all_notebooks[Interrupt.ipynb-opts6]'
+)
+
+python_test() {
+ # The tests run the pydevd debugger, the debugger prints a warning
+ # in python3.11 when frozen modules are being used.
+ # This warning makes the tests fail, silence it.
+ PYDEVD_DISABLE_FILE_VALIDATION=1 epytest
+}