summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-17 11:04:57 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-17 11:04:57 +0200
commit0374a8ddfabf84681abac96e264a1a420a0269f8 (patch)
treea88a09ceb75aaac93b866b24000b38e32e1df969 /dev-python/nbdime
parentdev-python/munkres: Remove old (diff)
downloadgentoo-0374a8ddfabf84681abac96e264a1a420a0269f8.tar.gz
gentoo-0374a8ddfabf84681abac96e264a1a420a0269f8.tar.bz2
gentoo-0374a8ddfabf84681abac96e264a1a420a0269f8.zip
dev-python/nbdime: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbdime')
-rw-r--r--dev-python/nbdime/Manifest1
-rw-r--r--dev-python/nbdime/files/nbdime-2.0.0-remove-bdist_egg-hack.patch36
-rw-r--r--dev-python/nbdime/nbdime-2.0.0-r1.ebuild56
3 files changed, 0 insertions, 93 deletions
diff --git a/dev-python/nbdime/Manifest b/dev-python/nbdime/Manifest
index 8c8d213e2950..8eb220b0879b 100644
--- a/dev-python/nbdime/Manifest
+++ b/dev-python/nbdime/Manifest
@@ -1,2 +1 @@
-DIST nbdime-2.0.0.tar.gz 7768807 BLAKE2B a92ed166ae863185d06e4b3e667df4323b4cd9af9211999109186c1b559522f39ab235b710c7993515aa3c44a55ac3c4b90c424cdc28d04cc013a58add7d61cd SHA512 e68e69e37f6ece701ba8d6e59d8ee321ddaca78d9338e0c52f92b6942bfd3fbf0ec2407e9ae98cb820eb4c26509644a1770f249b815c53265dfdbffbe2b55142
DIST nbdime-3.1.0.tar.gz 7508382 BLAKE2B 10ca59684df06e922afbba30d5419a20490508af8bb9d4f371b1a06db49df7b665195c9aec21c3a303b3fa0c60e5c0c1e57badaba27ac81599b311f9a5000244 SHA512 be19fc058a918cd2aad38a8f727504a01c7830dfaba7fbf06caa0a6799770824499a70f4efe1ebf0a82847dc79d84896baf9aa86d3e7cd16dd7163023fed3855
diff --git a/dev-python/nbdime/files/nbdime-2.0.0-remove-bdist_egg-hack.patch b/dev-python/nbdime/files/nbdime-2.0.0-remove-bdist_egg-hack.patch
deleted file mode 100644
index ff450f2ce447..000000000000
--- a/dev-python/nbdime/files/nbdime-2.0.0-remove-bdist_egg-hack.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/setupbase.py
-+++ b/setupbase.py
-@@ -129,17 +129,6 @@
- build_py.finalize_options()
-
-
--class bdist_egg_disabled(bdist_egg):
-- """Disabled version of bdist_egg
--
-- Prevents setup.py install performing setuptools' default easy_install,
-- which it should never ever do.
-- """
-- def run(self):
-- sys.exit("Aborting implicit building of eggs. Use `pip install .` "
-- " to install from source.")
--
--
- def create_cmdclass(prerelease_cmd=None, package_data_spec=None,
- data_files_spec=None):
- """Create a command class with the given optional prerelease class.
-@@ -179,14 +168,9 @@
- wrapper = functools.partial(_wrap_command, wrapped)
- handle_files = _get_file_handler(package_data_spec, data_files_spec)
-
-- if 'bdist_egg' in sys.argv:
-- egg = wrapper(bdist_egg, strict=True)
-- else:
-- egg = bdist_egg_disabled
--
- cmdclass = dict(
- build_py=wrapper(build_py, strict=is_repo),
-- bdist_egg=egg,
-+ bdist_egg=wrapper(bdist_egg, strict=True),
- sdist=wrapper(sdist, strict=True),
- handle_files=handle_files,
- )
diff --git a/dev-python/nbdime/nbdime-2.0.0-r1.ebuild b/dev-python/nbdime/nbdime-2.0.0-r1.ebuild
deleted file mode 100644
index 13f592127ee1..000000000000
--- a/dev-python/nbdime/nbdime-2.0.0-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Diff and merge of Jupyter Notebooks"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="webtools"
-
-RDEPEND="
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/GitPython[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/notebook[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]
- webtools? ( net-libs/nodejs[npm] )"
-BDEPEND="
- test? (
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/tabulate[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_sphinx docs/source \
- dev-python/recommonmark dev-python/sphinx_rtd_theme
-distutils_enable_tests pytest
-
-PATCHES=( "${FILESDIR}"/${PN}-2.0.0-remove-bdist_egg-hack.patch )
-
-python_configure_all() {
- use webtools || mydistutilsargs=( --skip-npm )
-}
-
-python_test() {
- # user.email and user.name are not configured in the sandbox
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
-
- distutils_install_for_testing
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}