summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-30 05:37:20 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-30 06:02:55 +0200
commit30b1a53124c43dab688839d94a50b4bdac66d9b8 (patch)
tree79f1cc049f6b057f10c7764c577ab21cc9a993fd /dev-python/openpyxl
parentmedia-libs/giflib: add 5.2.2 (diff)
downloadgentoo-30b1a53124c43dab688839d94a50b4bdac66d9b8.tar.gz
gentoo-30b1a53124c43dab688839d94a50b4bdac66d9b8.tar.bz2
gentoo-30b1a53124c43dab688839d94a50b4bdac66d9b8.zip
dev-python/openpyxl: Bump to 3.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openpyxl')
-rw-r--r--dev-python/openpyxl/Manifest1
-rw-r--r--dev-python/openpyxl/openpyxl-3.1.3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/openpyxl/Manifest b/dev-python/openpyxl/Manifest
index 1d3454889175..e9954806baa0 100644
--- a/dev-python/openpyxl/Manifest
+++ b/dev-python/openpyxl/Manifest
@@ -1 +1,2 @@
DIST openpyxl-3.1.2.tar.bz2 2733302 BLAKE2B 7030c698c2dfa3c3f27f23485e33cc9f4ffc0c473e590785ebfa03a958f7c1deab98503890b7350f32cbb4607b3fbf543b35299c0f8abfbfcc779e96ddda9ee1 SHA512 307d82dcf839c60be606c01f862701f69017573894c7fd26e35ec3edead2ea2a126aecca61b0c7f6727ff834dd6bed844095b9a56f2b510689ab071926a7a742
+DIST openpyxl-3.1.3.tar.bz2 2739587 BLAKE2B 64161f8ea0629f4bd2ef65187c2d1c0cfa23e155df7b5a4a81c386c48d339956e3d854da040157170852df19ab53d65fd0be9a4f1d4f5b5f6eed20e0fe1e89f9 SHA512 dee9dac201319ed6b3c14cb0cd396148a7caedebb2a95534a1b9fcb75afc445bfd73e67fdbd750334872e4bd3bf1a71d20c48930ff6b195f4f1c6312a5e762f8
diff --git a/dev-python/openpyxl/openpyxl-3.1.3.ebuild b/dev-python/openpyxl/openpyxl-3.1.3.ebuild
new file mode 100644
index 000000000000..e1d43c5174d6
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-3.1.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="
+ https://openpyxl.readthedocs.io/en/stable/
+ https://foss.heptapod.net/openpyxl/openpyxl/
+"
+SRC_URI="
+ https://foss.heptapod.net/openpyxl/openpyxl/-/archive/${PV}/${P}.tar.bz2
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/et-xmlfile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/lxml-5.0.3[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff,jpeg]
+ )
+"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # GC assumptions (pypy)
+ openpyxl/tests/test_iter.py::test_file_descriptor_leak
+ )
+
+ if has_version ">=dev-python/numpy-2[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ # https://foss.heptapod.net/openpyxl/openpyxl/-/issues/2187
+ openpyxl/compat/tests/test_compat.py::test_numpy_tostring
+ )
+ fi
+
+ epytest
+}