summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-21 19:13:24 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-21 19:17:14 +0200
commiteb11e64a0a4f71ddb0e36a1194a9a4960b8e9987 (patch)
tree075bfd21d08a0496ec080d7b92cb2c3c788560a3 /dev-python/oslo-i18n
parentapp-containers/kompose: drop 1.22.0 (diff)
downloadgentoo-eb11e64a0a4f71ddb0e36a1194a9a4960b8e9987.tar.gz
gentoo-eb11e64a0a4f71ddb0e36a1194a9a4960b8e9987.tar.bz2
gentoo-eb11e64a0a4f71ddb0e36a1194a9a4960b8e9987.zip
dev-python/oslo-i18n: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/oslo-i18n')
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-5.1.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/oslo-i18n/oslo-i18n-5.1.0-r1.ebuild b/dev-python/oslo-i18n/oslo-i18n-5.1.0-r1.ebuild
new file mode 100644
index 000000000000..ebd950ee136a
--- /dev/null
+++ b/dev-python/oslo-i18n/oslo-i18n-5.1.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Oslo i18n library"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.i18n/
+ https://github.com/openstack/oslo.i18n/
+ https://pypi.org/project/oslo.i18n/
+"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest