summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 13:12:25 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 13:17:40 +0100
commit2e0e1f45b87cab8db534ad2f12d71000ae691497 (patch)
treec800d7914f5fb1243888c8ea7b737965d1737e9e /dev-python/oslotest
parentdev-python/requests-kerberos: Migrate to PEP517 build (diff)
downloadgentoo-2e0e1f45b87cab8db534ad2f12d71000ae691497.tar.gz
gentoo-2e0e1f45b87cab8db534ad2f12d71000ae691497.tar.bz2
gentoo-2e0e1f45b87cab8db534ad2f12d71000ae691497.zip
dev-python/oslotest: Migrate to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/oslotest')
-rw-r--r--dev-python/oslotest/oslotest-4.5.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/oslotest/oslotest-4.5.0-r1.ebuild b/dev-python/oslotest/oslotest-4.5.0-r1.ebuild
new file mode 100644
index 000000000000..0759ca463b55
--- /dev/null
+++ b/dev-python/oslotest/oslotest-4.5.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Oslo test framework"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest