summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-06 21:31:42 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-06 21:40:55 +0200
commit82585c5eb817aaa03f5ae26efc0b803425b44abf (patch)
tree11d2cd834902bc11b06f357bc3e405e55d8f2bdc /dev-python/outcome
parentdev-python/anyio: Fix tests, PEP 517 build (diff)
downloadgentoo-82585c5eb817aaa03f5ae26efc0b803425b44abf.tar.gz
gentoo-82585c5eb817aaa03f5ae26efc0b803425b44abf.tar.bz2
gentoo-82585c5eb817aaa03f5ae26efc0b803425b44abf.zip
dev-python/outcome: Enable pypy3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/outcome')
-rw-r--r--dev-python/outcome/outcome-1.1.0.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/dev-python/outcome/outcome-1.1.0.ebuild b/dev-python/outcome/outcome-1.1.0.ebuild
index 9f4c94e538b5..722e60e24ead 100644
--- a/dev-python/outcome/outcome-1.1.0.ebuild
+++ b/dev-python/outcome/outcome-1.1.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
@@ -18,12 +18,16 @@ LICENSE="|| ( Apache-2.0 MIT )"
SLOT="0"
KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-RDEPEND="dev-python/attrs[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+"
-BDEPEND="test? (
- dev-python/async_generator[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
-)"
+BDEPEND="
+ test? (
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest
distutils_enable_sphinx docs/source dev-python/sphinxcontrib-trio