summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-19 12:00:45 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-19 12:48:50 +0200
commitb36882b2aac41d8dbfe577b8669d90e35e3f135f (patch)
treeb13c0d9053721ad1229b50985e6a9818d7000804 /dev-python/pastel
parentdev-python/networkx: Remove old (diff)
downloadgentoo-b36882b2aac41d8dbfe577b8669d90e35e3f135f.tar.gz
gentoo-b36882b2aac41d8dbfe577b8669d90e35e3f135f.tar.bz2
gentoo-b36882b2aac41d8dbfe577b8669d90e35e3f135f.zip
dev-python/pastel: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pastel')
-rw-r--r--dev-python/pastel/Manifest1
-rw-r--r--dev-python/pastel/pastel-0.2.1-r1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pastel/Manifest b/dev-python/pastel/Manifest
index ad6aaf29e8a7..5760732e413f 100644
--- a/dev-python/pastel/Manifest
+++ b/dev-python/pastel/Manifest
@@ -1 +1,2 @@
+DIST pastel-0.2.1.gh.tar.gz 125760 BLAKE2B f9b3c29444bb6bd0e710cd80d4e48cdc9099ad6512cd99b0224559b87504f5b61cfcb90165f97b101b8ff5e9f8b7e230878c5cf50ae2b0555447f5be28977cb0 SHA512 585834d035fe208313a77e0c824f6b67630a85697d4aef802800911cb1da72bfd6c9ba47fe5502359bdf244a98b8f6dea300a788ff1cfd56a8bc19eb7b7dcc16
DIST pastel-0.2.1.tar.gz 125760 BLAKE2B f9b3c29444bb6bd0e710cd80d4e48cdc9099ad6512cd99b0224559b87504f5b61cfcb90165f97b101b8ff5e9f8b7e230878c5cf50ae2b0555447f5be28977cb0 SHA512 585834d035fe208313a77e0c824f6b67630a85697d4aef802800911cb1da72bfd6c9ba47fe5502359bdf244a98b8f6dea300a788ff1cfd56a8bc19eb7b7dcc16
diff --git a/dev-python/pastel/pastel-0.2.1-r1.ebuild b/dev-python/pastel/pastel-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..b314489fc460
--- /dev/null
+++ b/dev-python/pastel/pastel-0.2.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Bring colors to your terminal"
+HOMEPAGE="
+ https://github.com/sdispater/pastel/
+ https://pypi.org/project/pastel/
+"
+SRC_URI="
+ https://github.com/sdispater/pastel/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+distutils_enable_tests pytest