summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-01 06:21:09 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-01 06:38:14 +0100
commit99d9e77bb674dade04cc18715cceba33b09dc562 (patch)
tree2468edb8945f5ca38626314bb477c65347209f98 /dev-python/patsy/patsy-0.5.4.ebuild
parentdev-python/cattrs: Bump to 23.2.3 (diff)
downloadgentoo-99d9e77bb674dade04cc18715cceba33b09dc562.tar.gz
gentoo-99d9e77bb674dade04cc18715cceba33b09dc562.tar.bz2
gentoo-99d9e77bb674dade04cc18715cceba33b09dc562.zip
dev-python/patsy: Bump to 0.5.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/patsy/patsy-0.5.4.ebuild')
-rw-r--r--dev-python/patsy/patsy-0.5.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/patsy/patsy-0.5.4.ebuild b/dev-python/patsy/patsy-0.5.4.ebuild
new file mode 100644
index 000000000000..c36201d8ef27
--- /dev/null
+++ b/dev-python/patsy/patsy-0.5.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module to describe statistical models and design matrices"
+HOMEPAGE="
+ https://patsy.readthedocs.io/en/latest/index.html
+ https://github.com/pydata/patsy/
+ https://pypi.org/project/patsy/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !hppa? (
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest