summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-06-11 23:18:59 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-08-05 11:12:14 +0200
commitfad50bed115ee51b84f50a1c9223e89200f73fe6 (patch)
tree10d679874f47e32f07f1b2ca271d3e0c5cbc7586 /dev-python/pcapy/pcapy-0.11.2.ebuild
parentdev-python/httplib2: version bump. (diff)
downloadgentoo-fad50bed115ee51b84f50a1c9223e89200f73fe6.tar.gz
gentoo-fad50bed115ee51b84f50a1c9223e89200f73fe6.tar.bz2
gentoo-fad50bed115ee51b84f50a1c9223e89200f73fe6.zip
dev-python/pcapy: version bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python/pcapy/pcapy-0.11.2.ebuild')
-rw-r--r--dev-python/pcapy/pcapy-0.11.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pcapy/pcapy-0.11.2.ebuild b/dev-python/pcapy/pcapy-0.11.2.ebuild
new file mode 100644
index 000000000000..78a8a1c5989d
--- /dev/null
+++ b/dev-python/pcapy/pcapy-0.11.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python pcap extension"
+HOMEPAGE="https://www.coresecurity.com/corelabs-research/open-source-tools/pcapy"
+SRC_URI="https://github.com/CoreSecurity/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="${DEPEND}
+net-libs/libpcap"
+
+python_test() {
+ cd "${S}/tests" || die "Unable to activate test suite"
+ "${EPYTHON}" pcapytests.py || die "Tests failed with ${EPYTHON}"
+}